View Full Version : Endless reboots, safe-mode goes as far as mup.sys

09.01.2005, 20:13
Operating System: Win XP Pro XP1
Burning Software: Nero ~6.3
Anti-virus Software: AVG
DAEMON Tools Version: 3.41

Hi there, I have a rather serious problem that I believe is DT related.

I cant boot into windows normal way, or safe-mode. After watching the XP logo and loading bar for a while the system shuts down and reboots. When i try safe-mode (that prints output) it stops at the line "mup.sys"

Mounting a dvd image (.img) of a film in DT, playing the content with MPlayer Classic worked fine, and I could start watching it. However, when i tried to fast-forward it the program hang. So i restarted it trying to do the same thing, but then the system hang and i got a blue screen. Smart as I am i didn't record what it said :( as i thought it was just something temporarily. When I tried to reboot it happened as I described above.

As I can't get in to windows I cant really do anything about it that way. However I have a dual-boot with linux (which allows access to the partition), or the option of putting it in another machine.

I have heard that users have experienced similar things with DT, and had to remove driver and install newer versions. However removing/renaming d***.sys is not an option for me since i cant find it. Anyone know what the corresponding driver is for version 3.41?

Or perhaps there is another way of getting into windows?

11.01.2005, 13:59
I did some more investigation:

As i thought a newly installed DVD-burner might have affected the system in some way i tried removing it, but it didn't change anything, still can't get inte windows.

The reboot happens just as the cd-drives spin-up during the boot-process (watching win logo) so I guess there must be a problem with either the img-file (which is automounting?) or the way it is mounted by DT and windows drivers.

Is there a way of stopping it from mounting during the startup, or am I "screwed"? I really want to avoid a format of the partition.

Another thing that bugs me is that I can't use the Win XP cd to repair/re-install either, it stops at "checking harware", which is kind of strange since that should be done independently of the current installation if I'm not mistaken.

I was really suprised when I got the blue screen since DT had worked smooth until then, therefore I thought it might have been the new DVD-burner that in someway disturbed DT, cause a corrupt image file shouldn't be able to screw up windows, should it?

Open to any suggestions...

11.01.2005, 14:25
Just disable automount, and the image should not be remounted at reboot.
Check if you've minidump from such crash (in Windows\Minidump folder), if so send it to support@daemon-tools.cc with reference to this thread.

11.01.2005, 17:09
Sorry, no minidumps. (Only found older ones) Dunno if it is because the system hang itself or some setting I hadn't turned on.

Where do I disable automount, if I can't get inteo Windows? Is there a command prompt, or can I delete some driver to stop it from automounting? (Can access filesystem from Linux)

11.01.2005, 17:29
Did you try to boot into safe mode (press ESC when prompted to abort loading of bus driver)?

11.01.2005, 20:36
Don't know if i write too long :P, think most of it is up there...anyway:

Can't get into safe-mode (hangs at mup.sys), never prompts me to press escape, although I have tried, without success. Correct me if i am wrong but i believed it only does that in later versions (using DT 3.41)

12.01.2005, 13:41
:lol: Sorry, answering too many posts at the same time may cause such problems :mrgreen:
If you've access to that Windows installation delete/rename Daemon Tools driver files in Windows\System32\Drivers directory and reboot, then remove Daemon Tools via control panel -> software.
Reboot, then try v3.47.

12.01.2005, 21:40
Thats kind of the problem... tried to find them, if names are obvious well, then I am a little stupid :P

couldn't find any d***bus.sys like in newer version (is using 3.41)...

12.01.2005, 21:56
Search for st3*.sys driver files, if you're unsure, ask us before deletion!

13.01.2005, 00:30
removed one called st3shark.sys, but it did't let me boot stopped att mup.sys again

starting to seem like daemon tools (or drivers involved by it) isn't the cullprit, more likely is that the image file was in someway corrupt, and during the windows crash it managed to make the partition so corrupt that windows couldn't boot (although strange cause windows itself is on another partition)

and still the win xp disc shouldn't fail to recognize hardware just because a partition might be corrupt

however, when reading the partition with the imagefile from linux, it reports a hd-read error from the file and the directory it is in

bit too strange situation for me, unless anyone has other suggestions, i will try a format and reinstall

13.01.2005, 09:36
Can you delete the image file (doesn't matter if it's corrupted anyway)?

13.01.2005, 16:26
Oops, clarification: the image has been deleted all the time (think i did that just after the crash) but the directory where i had it stored compressed is the one that generates the read errors. Although I had no problem reading it from windows before, when i unpacked the file, it generates a "input/output error" in linux.

Worth mentioning is that Linux has two ways of reading NTFS partitions: open-source read-only drivers (which are quite fast in what they do) and a program called Captive that uses the actual windows dlls and therefore can both read and write (but is quite slow).

The first way generates an input/output error on the directory, and the second only says "Operation not permitted" when trying to read the directory and therefore doesn't let me delete it.

What bugs me is that everything was running so smoothly, no warnings about corrupt files or anything like that, and then bang the whole system hangs and is unable to boot.

Judging from the symptoms (stop at boot while loading some driver) could it be like the "read-filesystem-driver" just as easily as the DT driver that is keeping me from booting?