PDA

View Full Version : Disabling Autorun



mhc
10.01.2005, 16:02
Operating System: Windows 2000 Pro
Burning Software: Nero
Anti-virus Software: McAfee Viruscan 8
DAEMON Tools Version: 3.47

:?: Is there anyway within daemon tools to disable a mounted drive from autorunning when it is mounted? Perhaps within a command line switch?

Copytrooper
10.01.2005, 16:48
Autorun is an OS feature, you've to disable it in Windows, not Daemon Tools.

Kompressor
01.06.2005, 15:37
Operating System: Windows XP Pro SP2
Burning Software: CloneCD
Anti-virus Software: Norton AntiVirus 2005
DAEMON Tools Version: 3.47

Isn't this a Daemon Tools issue? Because if I have a physical CD in my physical drive and I boot my computer, it doesn't autorun. But if I have the same CD image loaded in Daemon Tools, every time I boot up, it autoruns!

Does this happen with all virtual drive software or just Daemon Tools?

Copytrooper
01.06.2005, 15:42
No, auto insert notification (AIN) and autoplay/-run are Windows features, which can be en- and disabled for each drive separately. The easiest way is to change related settings in CloneCD, this is global setting for all drives though.

kel
03.06.2005, 22:51
Operating System: Windows XP SP2
Burning Software: Alcohol 120%, Nero
Anti-virus Software: Norton Antivirus
DAEMON Tools Version: v3.47

The only way I found to disable and enable autorun from a command line switch was to install BTEWin. It is a powerfull scripting interpreter that has loads more commands than you can use in normal batch files such as autorun on/off and all daemon tools commands as well. When you have made your script you can then turn it into a neat little exe file which will then work on any PC regardless of weither BTEWin is installed on it although if you want this feature then you have to download the previous version as it has been disabled in the latest version.

BTEWin is freeware and can be found on the Daemon Tools download page for third party tools and if it hasn't been changed yet then it should be the version that supports making exe files. If you want the latest version you will have to go to the VDesk & BTEWIN homepage.

Go check it out it's well worth it.

Also when you install it if you only want the scripting tool then only select BTEWin and uncheck VDesk and the other tool, cant remember what it's called now.

Woops, my reply was mainly for mhc but I didn't realise that post was from way back in january. What I wrote above probably wont help Kompressor as his problem is more to do with booting up with autoplay and not command line switches, sorry. If I had of realised that mhc's was from way back in jan then I wouldn't of wrote all this. Oh well maybe it might help somebody one day. :lol:

Reef
04.06.2005, 01:55
I think the OP means that every time Windows starts, Daemon Tools will re-mount the image that was mounted before the reboot, causing autorun to trigger.
If I'm not mistaking, this can be solved by disabling 'Automount' in Daemon Tools options. Or just make sure there is no image mounted before you reboot your PC.
I personally think it's a good habit to unmount images when you don't need them anymore.

Jaime
06.06.2005, 20:57
Operating System: _
Burning Software: _
Anti-virus Software: _
DAEMON Tools Version: _

The command that kel mentioned is the following (incl. description):

Autoplay on/off : This command turns on/off Autoplay for data CDs. The change is persistent.

The effect is immediate and persistent (remains after rebooting), so if you don't want to, it's not necessary to disable automount.