View Full Version : Error 1406 when installing v3.29

21.01.2003, 13:05
Getting this error:


Running XPSP1 and logged in as administrator.
Tried to reinstall my old version 3.26 but get the same error message.

Any help appreciated.

21.01.2003, 14:41
Run regedit.exe
Navigate to that key, and try making a new value.

If it errors in regedit, then right-click on the 'run' key, and goto permissions. Make sure administrators have full access.

Also, why can't you just push 'continue'. All this key does is to load daemon-tools on startup; you should be able to manually add this.

21.01.2003, 16:12
I can add new values manually and got full access for that key no problem.

When i push continue, then at the end of installation it performs rollback and tells me that the installer was interrupted and i need to restart installation so i can't manually enter the string later since nothing is installed.

Been suggested elsewhere that my registry might be corrupt but this is not a problem with any other application but D-Tools. I've tried to install other app that writes to the same run-key in registry without problems.

Could it be that the installer is corrupt?
I've tried redownloading it though.

21.01.2003, 16:27
hm, it is prolly an issue with windows installer. Could be due to the fact that it runs as a service. Can you goto permissions, and post the settings for every user in the list here? I doubt this is the problem, but I can't think of anything else right now...

21.01.2003, 16:42
You mean the permissions for the run-key?

Perm Administrator: Full Controll
Perm Creator Owner: Full Controll
Perm System: Full Controll
Perm Users: Read
Perm Power Users: Special

21.01.2003, 23:30
ok, then it is more than likely a problem with windows installer.

Specifically, this error means that the value could not be written. It may not (and prolly isn't) a problem with permissions.

I am sending you a setup that doesn't affect the registry, which will at least let you finish the setup.

22.01.2003, 18:36
Thanks for sending me the copy Andareed and it's not like i'm trying to be difficult or something but i can't install with this one either. :?

Getting this error:
Internal Error 2228. , Registry, SELECT 'Root','Key','Name','Value' FROM 'Registry','Component' WHERE 'Registry'=? AND 'Registry'.Component_'='Component'.'Component'

Then the same thing happens it performs a rollback and nothing is installed.

22.01.2003, 18:54
yeah, i know why that is. Give me a day or so and I will send you a new version.

23.01.2003, 10:18
Try to set 'Everyone - Full Control' to this key.

27.01.2003, 23:14
I tried to do as VeNoM386 suggested and it seems like xp wont allow me to give CREATOR OWNER neither full control or read permissions.

Should also mention that i tried to install Alcohol120% only to get a totally cryptic error message and then a rollback. :?

27.01.2003, 23:34
Right click the key, goto permissions, goto advanced, and untick 'inherit', then click yes. Now you shuold be able to modify permissions...

10.02.2003, 02:31
Has a fix been found for the "error 1406"

10.02.2003, 02:39
Not really.

You can try the following though: go into regedit, browse to the key in question, right-click, goto permissions, advanced, owner. Change owner to you username. Then goto Permissions tab, and add everyone, and set full access for it.

10.02.2003, 04:14
Thanks, But no go.

Same error. Shame too. But i'm assuming having to assume that possibly i have a corrupted registry as i tried to install acohol and it crashed on instal too.

I'll format tomorrow night and see if i can install after that, i'll let you know. :(