View Full Version : Error 25001, code 25021 when installing DT 3.29 on Win98SE

26.01.2003, 10:44
I'm trying to install on Win98, and I'm getting the following:

"Error 25001. Device setup error: code 25021. Contact your support personnel."

I've tried re-installing a couple of times - no luck. The first time it happened, I just ignored the message, but upon the next boot, Windows claimed to have found an unknown device, for which it couldn't locate/recognise any driver.

System info: Win98SE 4.10.2222 A.
Daemon Tools 3.29
CloneCD - no other burning software installed

It runs fine under Win2k on the same box, by the way.

26.01.2003, 10:54
Delete all unknown devices in Device Manager, go to WINDOWS\INF folder
and delete drvidx.bin file. Then try to run setup again.

26.01.2003, 17:14
Tried it, same results.....

What does the code actually mean?

27.01.2003, 09:48
It means Windows cannot find the driver in INF file or some other error in SETUPAPI occured. When you install Daemon - do you see the message 'Windows is rebuilding driver list' with progress bar or something of that sort?.

28.01.2003, 22:09
No, I don't get that far. I get as far as the "Installing DAEMON Tools" window, with the "DAEMON Tools is being installed" line, plus a full progress bar. It then takes about 15 seconds for the error message to pop up. When clicking OK, the roll back is performed.

Arjan H

28.01.2003, 22:17
Before clicking ok (before rollback);
can you goto device manager and see if you see ST??? under scsi or PNP Bios Extension under system.

30.01.2003, 16:18
Hi everyboby!

Got exactly same problem with 3.29 under win98.. :(

02.02.2003, 23:31
I've only got "Virtual CloneDrive" under SCSI controllers, and I've got "PnP BIOS" and "System board extension for PnP BIOS" under system. I Also have an "Unknown Device" there.

Arjan H

03.02.2003, 00:58
Can you try the following:

1) Right-click this unknown device, and report error code. If it wants drivers, try reinstall/update drivers, and maybe even point to C:\windows\inf.

2) Remove this device, reboot, and check device manager again.

Venom might have some more ideas too...

simon townsend
22.03.2006, 23:54
ive got the same problem but i use xp ive gone though the other sulutions and none of them match is it any different for xp