View Full Version : Command Line Autorun Problem...

05.04.2005, 13:25
Operating System: Windows XP SP2
Burning Software: Alcohol 120%
Anti-virus Software: AVG Antivirus
DAEMON Tools Version: 3.47

I just installed DT347 and love it! However, I am having a problem with the command line as follows:

1. I have a command line that mounts an MDS image on drive 0 (aka: daemon.exe -mount 0,"image.mds"). I have a shortcut that executes this command line.

2. The first time I run this shortcut, it mounts the image and executes the AUTORUN.EXE on the mounted drive just fine.

3. If I then double-click the shortcut again, Daemon.exe does nothing. I would think it would re-mount the image, causing the AUTORUN.EXE to execute once more. This is the desired effect.

4. If I then go in and unmount the image, the shortcut works properly again (for a single mount) .

Can anyone confirm if this behavior is "as designed"? I have had other image mounting software (such as 120% and the older Fantom CD) that would auto-remount the image if you called for the same image on the command line again and again.

I have worked around this by creating a batch file that first runs a -unmount command before the -mount command, but it shows up un the screen and looks really really tacky.

Any comments, answers or suggestions on this issue are VERY welcome.

Thanks again!

05.04.2005, 13:34
The image is not remounted if it's already mounted, if you want it that way, add an -unmount 0 to the command line before mounting the image.

28.04.2005, 07:27
Operating System: Win Xp
Burning Software: -
Anti-virus Software: -
DAEMON Tools Version: 3.47


I've a problem with the command line.

When a type in my Command Prompt

daemon.exe -mount 0, "C:\My Images\my_images.iso"

It returns me, that daemon.exe isn't recognized as a command.

Should I install something else to use Daemon Tools by command line ?

Don't know why it doesn't work.


28.04.2005, 07:45
I've found the solution of my problem...

Just have to give the complet path of daemon.exe, and supress the space between -mount 0, and 'the image path'. :roll: