PDA

View Full Version : Daemon Tools v4/Windows XP x64 support



NetSoerfer
10.05.2005, 16:01
There's been a lot of questions (polite or other) about the current status of Daemon Tools v4's development in this forum, and many may think development has been cancelled because there are no recent news.

Daemon Tools v4 will support Windows XP x64. That basically means that it has to be rewritten from scratch. DT uses a driver that's deeply anchored in the system, which is necessary for being able to fool copy protections. This takes a very long time. It's not just a simple printer driver, emulating copy protections is a very, very complex task, please don't forget that!

Furthermore, we're currently working on emulating StarForce 3, which also takes very much time. It's not as easy as it was two years ago, copy protection authors have been doing their homework as well and have included some clever mechanisms to find out if there is an actual original disc in an actual drive. It's very hard to fool them nowadays.

We are working on it. But a wholly new program spawns wholly new problems and bugs which have to be fixed before the release. We don't want to give you some partly-done, buggy software that doesn't work on many systems. We want to give you what you expect - a version of Daemon Tools that's as easy to use as the current version, that's stable and that supports as many copy protections as possible.

Finally, some words about the lack of news concerning v4: Of course there is progress in the development. But it's related to the code itself, not some features being added. And we cannot reveal anything about how DT works or it will be blacklisted before it's released. We are working on it, and we're making progress. But we simply cannot tell how many problems are yet to be found before we can release it, so we're just not able to say anything about when v4 will be released.

Please understand that this is all we can tell right now. No matter how often you ask, there's not going to be any more information about v4 until you read it on the news page.