PDA

View Full Version : Invalid Device



artek
15.07.2005, 12:52
Operating System: Windows XP Pro SP2
Burning Software: Nero
Anti-virus Software: NOD32
DAEMON Tools Version: 3.47

Daemon tools is installed but when I restarted the system it starts up with "Invalid Device" message. Checking the Device Manager, Under SCSI the SCSI/RAID controller is marked with yellow ! and reports "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"

ANy info greatly appreciated

Underheaven
15.07.2005, 16:50
What is the full name and version number(s) of the device(s) listed under 'SCSI and RAID controllers'?

Here are the instructions for uninstalling everything completely if the DAEMON Tools install program cannot remove itself fully.

Goto "the Common Problems and Solutions forum", the topic with uninstall instructions is the #1 stickied topic called "Error 25002, or how to remove Daemon Tools drivers"

http://www.daemon-tools.cc/dtcc/portal/forum.php

artek
16.07.2005, 00:37
Ok, what I should have mentioned was that when I tried to install Deamon tools (and Alcohol 120%) the system reboots with BSOD - coplaining about scsiport.sys.

So I have followed instructions for complete uninstalation of the drivers (both alcohol and Deamon Tools), then disabled my onboard raid controller (as it wasnt used) and also the offending scsiport.sys.

The daemon tools and Alcohol both installed ok, but they wont run.

The name of the device in device manager is plain "SCSI/RAID Host Controller" and its marked with the !

Thanks again

artek
16.07.2005, 00:39
Oh, and I dont have any Starforce drivers installed (as thats what is pointing to scsiport.sys errors)

Cheers!

Underheaven
16.07.2005, 01:19
Try to right click then properties on "SCSI/RAID Host Controller" and tell us the version number for the driver. It must have a version, so try looking on the second tab for it.

It seems like this is just detecting your onboard controller and maybe it wasn't installed completely in the past.

Can you try to uninstall it, also an option within the properties settings window?

artek
16.07.2005, 01:31
Driver Provider: Microsoft
Driver Version: 5.1.2600.2180

Thanks for the help

Underheaven
18.07.2005, 02:28
Well we seem to have isolated the problem. I am almost out of ideas as to how to help you, maybe someone else on this forum can butt in. As far as everything looks right now, it is not related to any burning or virtual drive software on your machine.

I have two ideas that you could do

a)

Maybe one of Windows built-in files has been corrupted. Find your windows cd-rom, insert it, then run "sfc /SCANNOW" and wait 30 minutes for your system files to be scanned to be sure they are unmodified.

microsoft.com link: Running Windows System File Checker (http://www.microsoft.com/technet/prodtechnol/exchange/guides/DROpsGuide/f91bdf6d-c665-447f-ac47-5b88bbb808af.mspx)

or

b)

Try to un-install the problematic device in device manager, if that doesn't work "disable" it in device manager and reboot. Then see if you can install DAEMON Tools or Alcohol 120% (http://trial.alcohol-soft.com/en/download_120.php).

artek
18.07.2005, 02:52
Thanks for the suggestion, but I already ran sfc /scannow and it didnt resolve my issue.

Uninstalling the issue doesnt seesm to help eighter, as after reboot its back there in the same state as it was before. SIGH. I am guessing it was something to do with the scsiport.sys file, that was corrupt. I guess I can try enabling my onboard RAID5 controller and reinstalling the scsi devices for it, hoping that this will replace the scsiport.sys.

Thanks for the help, i will keep you informed if I manage to resolve this

PS: I installed alcohol sucesfully but it doesnt work. Complains about virtual driver.

Underheaven
18.07.2005, 03:03
What if you un-install DAEMON Tools... if it prompts you to reboot go ahead and reboot if not then do the next step in device manager. Un-install the non-working SCSI controller/driver then say "No" when it prompts you to reboot, then try installing DAEMON Tools and running it before rebooting. ( C:\Program Files\D-Tools\daemon.exe is the default path of the executable that normally launches via autorun when you reboot )

The fact that it re-appears in the device manager is just a result of plug and play, try disabling it in device manager by right-clicking and then choosing 'disable', if you haven't tried that already. (And with the disable idea you could follow all the instructions from the beginning of this post except disabling instead of un-installing the non-working SCSI controller/driver)

artek
18.07.2005, 09:47
When I uninstall daemon tools all SCSI devices go, so I cant uninstall them.

I tried to disable it and then uninstall deamon tools, and it goes again.

Think its the missing scsiport.sys driver that causes the drama.

Thanks for all the help anyway, guess rebuild is due soon

rebo
10.08.2005, 12:04
Operating System: XP Pro SP2
Burning Software: None
Anti-virus Software: None
DAEMON Tools Version: 3.47

I have this EXACT same problem, with EXACT symptoms. Was this issue ever solved?

Thanks.

artek
11.08.2005, 00:13
No unfortunately mine is still not working and awaiting rebuild.
Please let me know if you get it fixed.

TheMerovingian
24.08.2005, 07:44
Operating System: Windows XP Pro SP2
Burning Software: Nero
Anti-virus Software: Kaspersky
DAEMON Tools Version: 3.47

Well i had the same error too. It only appeared to me after i have installed alcohol 120. So, i uninstalled alcohol but the problem persisted. I then reinstalled d-tools and restarted windows. D-tools was working now.

I think alcohol and d-tools have some kind of conflict between them when both installed, but i assume there is a way to have them both without causing this problem, yet i do not know how to accomplish this.

I hope this helps.

(sometimes u wonder why the computer is not working and try figuring out what's wrong, when all u had to do is plug the power plug :) )

Benn
28.08.2005, 14:47
Operating System: Win2k SP4
Burning Software: -
Anti-virus Software: Avast
DAEMON Tools Version: 3.47

When I try to install the tools my system crashes and after reboot I also have the massage of device failure.
I suspect the chipset driver too, because I have similar problems with other emulation software like Slysoft Virtual Clonedrive.

Copytrooper
28.08.2005, 14:49
Check if you've minidump (in Windows\Minidump folder) related to that BSOC/crash, send newest file to support@daemon-tools.cc with reference to this thread.

wildcat757
27.09.2005, 15:08
Operating System: win98 se simplified chinese
Burning Software: no
Anti-virus Software: zonealarm antivirus
DAEMON Tools Version: daemon 3.47

thanks god.this problem for me is solved.i previously installed gamedrive on pc for playing game.once i install daemon, the "invalid device"problem
appears.i suspect that this software conflict with gamedrive.so i uninstall
gamedrive and daemon,and try install daemon again.the problem persists.
i check device manager and found the scsi device is disabled. i reenable it.
the daemon now work fine.so the scsi devie is disabled by conflict when i install daemon first time. if i unstall gamedrive at first, then install daemon.the problem should not appear. hope this will help others.