PDA

View Full Version : autoload an iso when double clicked?



Fillzter
28.07.2005, 13:59
Are there any ways of making this happen? I need the program to load the image when I double click on it. In this case it is impossible for me to take use of the command "-mount 0,''".

Anyone?

Underheaven
28.07.2005, 15:51
Yes, there are ways. See Downloads, 3rd Party Addons section. Listed are: awxDTools, FastMount, MountDaemon, DaeMount, etc.

CongoMan
28.07.2005, 17:16
---------------------------------------------------
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.iso]
@="iso_file"

[HKEY_CLASSES_ROOT\iso_file]
@="iso file"

[HKEY_CLASSES_ROOT\iso_file\shell]
@="open"

[HKEY_CLASSES_ROOT\iso_file\shell\open]

[HKEY_CLASSES_ROOT\iso_file\shell\open\command]
@="C:\\PROGRAMME\\D-Tools\\daemon.exe -mount 0,\"%1\""
---------------------------------------------------

Hi there!

THIS will fit your needs. Save as .reg, d-click it and off you go!

Fillzter
29.07.2005, 11:27
---------------------------------------------------
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.iso]
@="iso_file"

[HKEY_CLASSES_ROOT\iso_file]
@="iso file"

[HKEY_CLASSES_ROOT\iso_file\shell]
@="open"

[HKEY_CLASSES_ROOT\iso_file\shell\open]

[HKEY_CLASSES_ROOT\iso_file\shell\open\command]
@="C:\\PROGRAMME\\D-Tools\\daemon.exe -mount 0,\"%1\""
---------------------------------------------------

Hi there!

THIS will fit your needs. Save as .reg, d-click it and off you go!

Alright, that would do the trick. But if I change .iso to .img (for .img files) it doesn't work! It just say "error in command line". Why?

zdfz
29.07.2005, 11:36
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\Shell]

[HKEY_CLASSES_ROOT\*\Shell\Mount]

[HKEY_CLASSES_ROOT\*\Shell\Mount\Command]
@="d:\\d-tools\\daemon.exe -mount 0,\"%1\""

[HKEY_CLASSES_ROOT\*\Shell\Unmount]

[HKEY_CLASSES_ROOT\*\Shell\Unmount\Command]
@="d:\\d-tools\\daemon.exe -unmount 0"

this is the one I use, so in the right click menu, if no programs associate with img, iso etc, you may double click to mount.

Fillzter
29.07.2005, 12:04
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\Shell]

[HKEY_CLASSES_ROOT\*\Shell\Mount]

[HKEY_CLASSES_ROOT\*\Shell\Mount\Command]
@="d:\\d-tools\\daemon.exe -mount 0,\"%1\""

[HKEY_CLASSES_ROOT\*\Shell\Unmount]

[HKEY_CLASSES_ROOT\*\Shell\Unmount\Command]
@="d:\\d-tools\\daemon.exe -unmount 0"

this is the one I use, so in the right click menu, if no programs associate with img, iso etc, you may double click to mount.

well, I still get the error message from *.img files :(

EDIT: and if a file isn't associated with anything, I get the regular "select program" list...

BrianWarming
07.08.2005, 09:26
Just use FastMount 2, works great (also with IMG files)

http://www.normanbauerservices.de/index.php?s=fastmount&c=download

Underheaven
08.08.2005, 07:02
BrianWarming (http://www.daemon-tools.cc/dtcc/portal/profile.php?mode=viewprofile&u=31261), thanks for making a recommendation. I just want to point out that FastMount v2.0.1.82 is also hosted on the DAEMON Tools website (if anyone wants to download it):

http://www.daemon-tools.cc/dtcc/portal/download.php?mode=Download&id=33

Fillzter
08.08.2005, 14:20
Excellent! Fastmount 2 works perfectly! The only trouble now is, somehow the 'auto-insert' function in windows is disabled. Anyone know how to enable it? (options @ cd-rom doesn't work).