View Full Version : Dtools broke ASPI, Audiocatalyst creates incorrect track length or no aspi support at all.

09.08.2005, 14:57
Operating System: win2k sp4 / xp sp2
Burning Software: Nero 6,6,0,12
Anti-virus Software: AVG 7
DAEMON Tools Version: 3.47

:evil: Dtools Has killed my ripping program.
I have done testing, everything works fine till the installation of of dtools then audiocatalyst creates wierd tracklengths.

if dtools is installed b4 audiocat, the aspi layer fails to become and option.

tried reinstalling both aspi and audiocat.

deleting all aspi files (inc dll's ) and wowexec files to try and get a refresh and searched registry for clues. No luck

any one got any idea's this ones got me stumped.

09.08.2005, 22:14
This webpage http://radified.com/Files/ has a program called ASPI Check. Maybe reading around on that website will help.

10.08.2005, 13:10

This is just the aspi check that comes with the adptec drivers, it states that all is good....

the best aspi drivers i ever used and still have a copy of were from the old nt days. I am talking aspi32v460 and the aspi check that came with that program finds errors that the new ones dont see.

I had a thought though

If any one knows how to completely reinstall the aspi layer or remove it completely for reinstallling. i think the error lies in the registry or the low level hardware interface maybe a binding to the ide controller.

10.08.2005, 23:43
Well i don't know if me myself and i got too much to add...
But Hell yeah - you are using AudioCatalyst - which version? - way good soft but i'm using it on 98SE - i just ONCE tried shoving over my 2.0 version over to ONE 2K(SP unknown if even any) system... would ONLY work with a certain Third-Party ASPI layer on this machine, and WAY slow (read speed 1.X) - and to ONE XP System (SP none or 1, not mine...) - would NOT be able to use ASPI even though it WAS properly installed, according to ASPIchek (just standard Adaptec stuff with all of that from my side)

My main interest in here would really be - how did you get AudioCatalyst - which version ever - to properly run in ASPI mode on your NT5 systems? Looks i have NOT been able to figure this one out - though i've not EXACTLY been spendin' hours at it...

p.s. Nope, i sort of don't believe that DT is a culprit here.

11.08.2005, 09:51

To Get Audiocatalyst to work on 2k/xp machines in aspi mode was an accident.
but i will tell you the secret......

if you have ever installed dtools it wont work....... ever!
unless some one can tell me how to set windows back to pre dtools setup.
and i tried force aspi, all it did was what i do manually. Nothing happens.

dtools does something, i dont know what but it so far unchangeable, might do a fresh install and run filemon and regmon to find out....

any way here is the secret to get audiocat to run on nt5 machines.

install new adptec aspi drivers, reboot.
then install adaptec aspi driver version aspi32v460.exe this is for win95/nt
presto! aspi is now an option on audiocat!

with no side effects
untill you install d-tools then is aspi is allready selected you will still have access to it..... but! any mp3's ripped will have some wierd stuff happen, like track lengths for 14 minutes for a 3-4 minute songs that constantly reduces when played, till it finnally get to the right tracklength in winamp, just to reset when you play it again.

RE to your ps, yes DT did do it. i did a second intall on a spare pc.
Here is the order, OS + service packs then ASPI then Audiocat then Testing it was all good. then DT then testing. Audiocat died.

I am not ragging on the product i think it is fantastic. Have a lot of old cds full of data that i mount and DT is fantasic i just wish i could figure what it changes so i can setup some sort of batch file or regkey install so when i need to i can rip cds.

BTW this is audiocatalyst 2.10 the best ripper ever.
if any one has a suggestion for a better one that will work afer a dtools install let me know.