View Full Version : CD Drive disappears during games

11.08.2005, 02:09
Operating System: Windows XP Professional with Service pack 2
Burning Software: Nero 6
Anti-virus Software: AVG Free version 7.0.338
DAEMON Tools Version: 3.47

Hi all!¬) Well here goes,

I installed service pack 2 whilst daemon tools and Alcohol were installed had the

obligutary atapi.sys locked error so I renamed the atapi.sys file and installed service pack

2 without any problems or so I thought!

When I have daemon tools installed, when I run any image/game my pc stutters during the game

then my cd rom drive disappears (Lite on Ltr 52246s with the latest firmware) and my Teac

w50e dvd drive light comes on and off with no disk in it! (The Teac being on the secondary

ide as master the Lite on as slave) What fun! I used to be in I.T. but this has stumped me


In my event log I then get a
atapi 9 error initially The device, \Device\Ide\IdePort1, did not respond within the timeout


then a atapi 11 error The driver detected a controller error on \Device\Ide\IdePort1.
then a ataoi 12 error The device 'LITE-ON LTR-52246S'

(IDE\CdRomLITE-ON_LTR-52246S______________________6S0D____\5&37c4be1a&0&0.1.0) disappeared

from the system without first being prepared for removal.
then a atapi error 25 The driver has detected a device with old or out-of-date firmware.

The device will not be used. Laughing yet? !¬)

I noticed in Device Manager on my Secondary IDE channel driver details my atapi.sys is the

latest 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158) but isnt shown as digitally signed when I

copy the file over c:\windows\system32\drivers it still hasnt changed, the only thing I can

do is to remove it (the Sec IDE) and reboot or update the driver then its shown as digitally

signed until I reboot again it goes back to being NOt digitally signed, :(

All I can do to run the game is to disable both my drives and run the image with daemon

tools this time no stutters in the game but when I exit my Lite on drive hops annoyingly

enough to unknown device until I reboot to get the drives back again.

All this never happened pre Service pack 2, yes Ive tried uninstalling Daemon tools and

alcohol then uninstalling service pack 2 then reinstalling it but still the disappearing

drives during the game, and the atapi.sys isnt digitally signed etc which makes me think

that this is the cause of the problem? :?

What do you think I should do to resolve this without a complete reinstall of xp? (Oh why

didnt I set a restore point!)

I havent tried swapping the master and slave drives yet though!

Overall I would like to congratulate you all for an excellent piece of software that Daemon

tools is, saved me many a night swapping discs!) :D


ASUS A7V8X motherboard Northbridge VIA KT 400 Southbridge VIA VT8235
1GB PC3200 Ram
255 Gb HD
ATI X800 XT PE (Very nice!¬)
Teac W50E DvD RW
Lite on Ltr 52246s

(I also have the latest motherboard bios installed with the latest Via 4in1 drivers to


11.08.2005, 06:49
Operating System: xp pro sp2
Burning Software: alcohol & nero
Anti-virus Software: mc afee
DAEMON Tools Version: 3.47

Personally I had do this : try to desinstall, in this order

1) SP2
2) DT and Alcohol

Ok, now I suppose that we all you action it is difficult to it. But try it (if it is not done yet)

Have you an old restoration point ? Or better a ghost image of your system before the sp2 update ?

:( Hem, it smell "format c:" and reinstallation...

11.08.2005, 16:17
Thanks Kendo, have tried uninstalling Alchohol, Daemon Tools then reinstalling service pack 2 and same thing happens. Disappearing CD/DVD drives during playing any game. I have a file called Pxhelp20.sys in windows\system32 \drivers that is not digitally signed on each of my optical drives Hmm!¬) Also I have noticed that I have a file called UAService7.exe in my windows\system32 folder that is constantly running in task manager, wonder if that has anything to do with it? Unfortunatley I have no restore point, and I am thinking of ghosting in future! Any more help/ideas? Cheers :)

11.08.2005, 20:08
"have tried uninstalling Alchohol, Daemon Tools then reinstalling service pack 2 "

I don't wrote that

Desinstall SP2 (it possible)
Desinstall Alcohol
Desinstall DT

Does the CD/DVD reapear ???

Do you have Symantec WinDoctor (and utility from Norton System Work). IF yes try to run it, it is not a miracle maker, but a useful utilty to check and repair the system.

If it work, update with SP2


install Alcohol & DT

and make a ghost image .... :wink:

11.08.2005, 23:14
Thanks will do! The CD/DVD drive appears every time I reboot, its just when I have a loaded a .cue or .iso they disappear when I run it! Ive thought about it a while and havent checked when I uninstall D-Tools if there is any SCSI or RAID controller left over, also Ive checked on the net http://www.winxpforums.com/ftopic99295.html and someone has a similar problem, like the atapi.sys file is not digitally signed! :?

I had it working for a day or two with service pack 2 installed myself so there must be something else going on with said annoying file!) Thanks again, will still try uninstalling/reinstalling. Hopefully some of the site admin will have an answer for it! :wink:

Random fact 312:
My favourite film is Bladerunnner what is yours? :)