PDA

View Full Version : "Invalid device" on every boot, working on manual 2nd attempt



hselig01
15.09.2005, 19:47
Operating System: Windows Server 2003 SP1
Burning Software: none
Anti-virus Software: NOD32
DAEMON Tools Version: 3.47

I had Daemon tools working nicely for years now. Last weekend I had to reinstall my server ('repair') due to some very weird Explorer problem... Now after booting the machine, when I log in I get an alert headed "DAEMON tools" saying "Invalid device.".

When I at this time look into the device manager, there is no entry for the SCSI driver and none for the CD-ROM drive. If I then click "OK", I get the same dialog a second time, but now the SCSI-device and the CD-ROM show up in the device manager, just the toolbar icon is missing.

If I now start daemon.exe again manually, it works just fine.

Tried to disable the start upon starup (HKLM/.../Run) and start manually, same behavior, 1st start gives errors, 2nd works. Tried proper remove (including checking the registry), rebooted a zillion times, to no avail. Finally copied d347[bus|prt].sys from another machine where it works, also no change.

SCSI driver is showing Microsoft/01.10.2002/version 5.2.3790.1830/Microsoft Windows Publisher.

Any ideas what could be wrong here? Anything else I can try? Any help appreciated!

Cheers,
Hendrik

Copytrooper
15.09.2005, 19:59
This is a known issue with 2003 Server - disable autostart in Options menu and start Daemon Tools manually after boot.

hselig01
16.09.2005, 12:18
Thanks for the reply. Strange thing though that I have been running the server for quite some time already without the slightest problem, only after the repair-reinstall did it show up. So there's got to be a way to make it work, but I'm not going to try simply reinstalling the server to do so.

Also, if I manually start after boot I still get the same problem: start daemon tools, respond to two error-dialogs, and start daemon a second time. Could automate this, but that doesn't sound like the right approach. If it's a known issue, is there also a known cause I can build my "manual" approach around?

Thanks again,
Hendrik

Underheaven
19.09.2005, 08:57
First reported here: Windows Server 2003 SP1 breaks daemon tools (http://www.daemon-tools.cc/dtcc/portal/viewtopic.php?t=4985)

VeNoM386 (http://www.daemon-tools.cc/dtcc/portal/profile.php?mode=viewprofile&u=3) mentions the cause in that thread.