View Full Version : Daemon Tools not seeing some files on the image

21.02.2003, 01:59

I'm using Daemon Tools 3.29 and I noticed that sometimes I can't read files from images (CRC errors, and sometimes when I try to open a folder Windows Explorer kind of locks). I still didn't figure out if the problem is with the fact that I edited the .BIN image using WinISO 5.3 in order to add more files, but the fact is that the same .BIN image (after edited) works well when burned to the CD or if browsed using WinISO.

Any idea of what the problem is?


21.02.2003, 05:11
The prob may be that Win iSO has corrupted ECC of sectors.
But when you burn your image all sectors are corrected by burner.

04.03.2003, 16:55
I have this problems on some images (.BIN, .CCD, .ISO). Esterday i mount .BIN image with WinXP and some files have incorrect data when i viewed it (in FAR pressing F3). In ROOT directory all files are OK, but more of all files who placed in other directories are incorrect (filled zeros or contents information from other file types).
I think this images contains incorrect VTOC, and DT incorrect emulate that.
I don't thing that image has "corrupted ECC of sectors" (else why .ISO image have this problem too? .ISO contain only DATA bytes (2048 or 2536)as i know.)

04.03.2003, 21:59
Your knowledge about ISO is wrong - 2352 ISO contains EDC/ECC too.
Also Daemon Tools does not emulate anything on file level - in just plainly supplies sectors from image to application that requests it. It is Windows file system (CDFS) that cannot see some files due to corrupt information.

05.03.2003, 08:27
ok, i can mistaken about ISO format. But if some sectors on image have incorrect ECC, it must be unreadeble for system or not? In my case i can read this sector (and file).
Let guess i agree with you. Then image has contains errors (incorrect ECC data)? But when i write this image on CD-R in RAW-DAO (or RAW-DAO 96) mode that errors just corrected by burner or no? I think no.

with Respect...

06.03.2003, 09:59
Can you reproduce this problem every time on any image?
Does it happen only after you edit image with WinISO?
What are these images from (what games etc).

18.04.2003, 17:57
I experienced the same problem using Daemon 3.29:

I mounted images of MOO3 and Icewind Dale II and tried to install but the installation prog reported CRC errors while installing some files. The games seemed to work afterwards though...
This was reproducable.
I burned the images on CD using Nero in DAO/96 mode and they worked fine.

The images were bin/cue but they had some files (i'm not going into details due to forum rules 8)) added afterwards. I don't know which program was used though...

I recently updated to 3.32 but did not have time to install the games again
but i copied a file from an image to my hd and compared the two.
I noticed something really strange: the differences was always 8 hex in one byte. e.g.:
byte no 492f1 would say 28 on the virtual cd and 20 on hd
59209: 18 /10
698b1: bb/b3 etc.
also you can see that the last number of the address is always 1 or 9

well, i hope that helps...