View Full Version : Install Error 25030

08.10.2005, 17:32
Operating System: XP SP2
Burning Software: Nero 7
Anti-virus Software: NOD32
DAEMON Tools Version: 3.47

i get this when i try to install dt,
and i get this when i try to install alcohol,
i've tried just about anything i could find on google and in here but i'm stuck, please help
Here are some logs (if it helps)

MSI (s) (D8:18) [18:29:57:171]: Executing op: CustomActionSchedule(Action=DaemonDriverInstall,Ac tionType=3073,Source=BinaryData,Target=_DaemonDriv erInstall@4,CustomActionData=d347bus;d347prt)
MSI (s) (D8:4C) [18:29:57:187]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSI54A.tmp, Entrypoint: _DaemonDriverInstall@4
MSI (s) (D8:18) [18:29:57:187]: Generating random cookie.
MSI (s) (D8:18) [18:29:57:218]: Created Custom Action Server with PID 7864 (0x1EB8).
MSI (s) (D8:F4) [18:29:57:296]: Running as a service.
MSI (s) (D8:08) [18:29:57:296]: Hello, I'm your 32bit Elevated custom action server.
DEBUG: Error 2835: The control ErrorIcon was not found on dialog ErrorDialog
The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2835. The arguments are: ErrorIcon, ErrorDialog,
Error 25001. Device setup error: code 25030 (0x61C6), -536870389 (0xE000020B) . Contact your support personnel.
MSI (s) (D8!E4) [18:31:15:781]: Product: DAEMON Tools -- Error 25001. Device setup error: code 25030 (0x61C6), -536870389 (0xE000020B) . Contact your support personnel.

08.10.2005, 22:55
A simple search for 25030 and you'd know the answer:
You MUST reboot before re-installation!

08.10.2005, 22:58
a simple search and i'd know this is an open issue with no solution yet.
rebooting doesn't help since I'M NOT REINSTALLING!

09.10.2005, 11:19
Operating System: yes
Burning Software: two
Anti-virus Software: of course
DAEMON Tools Version: 3.47

try removing then re-installing changing the names of the drivers.

09.10.2005, 16:43
i have nothing to remove since the install is rolling back at this stage
changing the names of the drivers didn't help

10.10.2005, 12:16
Check permissions of HKLM\System\CurrentControlSet\Enum hive in registry.
Did you use some anti-blacklisting tool, or did you change some registry permissions?

10.10.2005, 18:45
didn't find anything wrong in the permissions there, my user (administrator) has full access, and system has full access, regular user has read access.
and just to be safe i ran an overwrite on all permissions down the tree just to be sure and still i get this error.
i have microsoft anti-spyware, agnitum outpost pro, nod32, and that's about it.
i have no registry repair programs at all, so i really have no idea why this is.

15.10.2005, 02:08
OK, first, go to regedit, HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\R oot
It is most likely you'll see it is a tree key, but it doesn't want to expand. that's actually the problem. Why? Download some other regeditor (3rd party), i found this one: www.download.com/3001-2094_4-10380103.html
Then go to this path, and you'll discover gibrish keys (something like 10 or so) at the begining, delete them all (be carefull, real ones are right under them) and that's it.

15.10.2005, 10:10
You shouldn't delete keys! At least without making backup!