PDA

View Full Version : My CDROM is MISSING i did the steps in #8 Common Problems thread



bcboncs
18.10.2005, 01:17
Operating System: Windows XP Professional
Burning Software: None
Anti-virus Software: None
DAEMON Tools Version: 3.47

Daemon Tools was installed by me so i could mount an image and view it, it was National Treasure or another movie not sure, i did this and a friend recommended this program. So i tried it and there was some error (don't remember, hopefully doesnt matter) anyway... i uninstalled it and tried to just play starcraft or something and i needed the cd and it wouldn't detect my cdrom and its not showing up in bios or device manager, i dont know what the version of daemon tools was at the time i used it, but i installed it and load one virtual drive just so i can see in it My Computer, makes me feel happy.

The drive doesnt work of course, it's not the CDROM drive either i've tried two and both don't show up until i load one virtual drive.

I've tried the steps in common problems thread #8 and well I didnt even see the Upper Filter folder in the registry and all i saw was the Lower Class one.
The Lower Filter folder had this inside it PxHelp20. Thats it, other things in this other than Lower Filter are Class, EnumPropPages32, Icon, Installer32, LowerFilters, NoInstallClass, SilentInstall, TroubleShooter-0

Please if anyone could help i've had this problem forever, i always thought it was daemon tools that did this but, when i told my friend, just said i'm an idiot and daemon tools cannot do that. i insisted calling my cdrom manufacturer at 18003470000 or something like that the 347 isnt it i just winged that and they said the cdrom is broken, clearly isn't because 2 cdrom drives have this problem and after using daemon tools, this problem started, again i am rambling but i really want to get this problem resolved giving whoever is going to help me (hopefully) with the most information i possibly can give/remember. Thanks alot everyone : ) I'll check this thread tomorrow in school around 12ish hopefully you guys have an answer by then, if not i'll be patient, problem has happened for like 5 months :/

Copytrooper
18.10.2005, 20:53
What exactly did you try?
The procedures mentioned in linked Microsoft article?

bcboncs
19.10.2005, 04:44
yeah i did those then realized that after installing xp, not daemon tools, so i undid everything cause i did the savekey.reg or something like that and did the other one, not the link the one below it


in other words, i did both, the link and below it

bcboncs
19.10.2005, 16:40
help meh out z0r :(

bcboncs
19.10.2005, 22:59
please i need some help, i'll try to post my image what i see and stuff like that

not too artistic, but when i set the number of devices at 0, there is no cdrom in the device manager or in my computer, it shows the cdrom in my computer and in device manager when its enabled though :/

http://img92.imageshack.us/img92/823/cdrom0wo.th.jpg

Underheaven
20.10.2005, 02:57
I'm having trouble understanding what the problem is :? How many CD-ROM drives do you have in your computer? Can you list all your burning software? Your real CD-ROM drives don't appear at all unless you have 1 or more virtual drives enabled withing daemon tools? Hmm. Have you ensured your CD-ROM drives are not to blame by installing them inside another desktop computer? I assume this does not happen with a fresh install of windows XP (though I'm not recommending that).

p.s. Your image was very small and didn't enlarge or anything.

bcboncs
20.10.2005, 03:50
bah i try to be descriptive as possible, but since you dont understand i'll be glad to help you understand so you can help me out, i appreciate you taking your time to do so.

1 cdrom in my computer

I've tried two cdroms, 1 this happened to, and one that works definitely, in this computer and the one in it now works for sure and it doesnt show up like my last one, i'm guessing DT messed up something in my registry but i donno what i'm talking about prolly.

I don't want to resort to reformatting unless i'll have it...

I have nero 6 express or something like that but i've never used it... even though i have a cd-rw

"Your real CD-ROM drives don't appear at all unless you have 1 or more virtual drives enabled withing daemon tools?" - Exactly.

Underheaven
20.10.2005, 04:50
I have to say this problem seems complicated. The easiest solution seems to be forget re-installing windows and just always leave 1 virtual drive enabled ( :wink: ). But I wouldn't be happy accepting that kind of work around solution on my computer.


Are your currently installed CD-ROM drives showing up inside your BIOS? You could try uninstalling your primary and secondary IDE channel using the device manager and reboot immediately afterwards (use device manager - and of course make a system backup before doing risky stuff like this, though I've done it a few times and don't think its risky)

Read this link (http://www.daemon-tools.cc/dtcc/portal/viewtopic.php?t=3916) from the Common Problems and Solutions forum and post all the drivers your real CD/DVD-ROM's are using (ex. cdrom.sys, storprop.dll, and redbook.sys) - that thread explains about viewing what cd/dvd-rom drivers are being used. Also check to see that the drivers listed for DAEMON Tools' Virtual CD/DVD-ROM are identical.

Copytrooper
20.10.2005, 09:13
Well, you can try it the "hard" way, shutdown, disconnect your drives, boot into Windows, shutdown again, re-connect your drives, boot again -> Windows should re-detect the drives.

bcboncs
20.10.2005, 21:15
I Forgot to mention this weird problem

ever since this has happened, i restart and it prompts me to install a printer, i don't even have a printer, i think its telling me that my cdrom wants it's love back :(

is it showing up in BIOS? - Nope. :(

about the drivers...
These drivers are installed on the virtual cdrom
cdrom.sys imapi.sys PxHelp20.sys redbook.sys storprop.dll

Going to try the uninstallation of my IDE drives

Underheaven
21.10.2005, 01:22
I was mentioning channels, not drives nor controllers.

p.s. The BIOS issue seems to explain it all

Underheaven
21.10.2005, 03:02
oops, just realized Copytrooper was talking about removing/redetecting the drives :wink:

bcboncs
21.10.2005, 04:29
any other solutions besides reformatting?

i tried to reinstall the controllers, i have two hard drives, 20gb winxp drive
and a 250gb game/movie/tvshow drive

my 250gb is a sata drive, for some reason when i uninstalled the controlled (secondary ide, my cdrom is on it ONLY CDROM) my 250gb sata drive was uninstalled (nothing lost of course).

that seems weird to me, any other possibilities that i can do to getting my stuff fixed? i appreciate anything at all :o

Copytrooper
21.10.2005, 10:03
Uhm, what is not showing in BIOS? The cd/dvd-drive(s) or the printer port?
Without the drives getting detected on BIOS level it won't work in Windows for sure.

Jito463
21.10.2005, 13:12
Operating System: .
Burning Software: .
Anti-virus Software: .
DAEMON Tools Version: .

You could try a repair install of Windows.

1) Restart your computer with the XP disc in and press a key when prompted
2) After setup goes through it's startup routine, choose to install (ENTER) on the first prompt
3) Press F8 to accept the license agreement on the next page
4) At this screen, you should get an option to press R to automatically repair Windows. Choose this.

Go through the prompts, inserting your product key when requested. You may have to install some drivers and any service packs not already integrated on your disc (best to have those downloaded ahead of time).

bcboncs
22.10.2005, 00:10
anything other than repairing / reformatting? :[

i've tried switching ide cables also, that didnt work either.

bcboncs
22.10.2005, 18:35
Figured it out, after days / hours...

Daemon tools some how fried my secondary IDE controller, no big deal not gonna point the finger or anything : ) !!! <3 WARRANTIES !!!

MSI 865PE Neo2-P


Thanks guys!

Copytrooper
22.10.2005, 18:51
For sure Daemon Tools didn't do anything to your secondary IDE controller.

Jito463
23.10.2005, 04:39
I'm a tech and do it for a living. I can guarantee you that software cannot fry your IDE ports. It's simply not possible. Coincidences do happen, you know.

Absolute0
23.07.2006, 20:27
Rather than create a new thread i am going to bump this one. I am experiencing the same problems as the Original Poster.

After using DT, my CD Rom drives will not detect. They do not show up in the BIOS, they do not show up in the Device Manager. I've tried every combination of IDE connection and settings between two drives and I cannot get anything to detect. Even with DT on and virtual drives enabled, the real drives do not show up, only virtual drives.

I've tried the walkthrough here
http://support.microsoft.com/default.aspx?scid=kb;en-us;320553

Method 1 doesn't work because the registry files are missing.
Method 2 doesn't work because Device Manager doesnt' detect anything.

I'm stumped, i'll do anything short of reformatting, please help.

Copytrooper
23.07.2006, 21:31
First you've to figure out why they are not detected on BIOS level. Check all cables (power, IDE) on mainboard and drives, also check all BIOS settings. If drives are not detected on BIOS level, reformatting won't help.

Hotaru
24.07.2006, 05:16
I am really concerned about any chance DT might have nuked my drives and/or IDE secondary now that I have developed the same problem. Does DT do anything at Ring 0 or Ring 1?

Win2000 became unstable, as seems to happen every 1-2 weeks or so. It was unable to finish shutdown and I had to hit the reset button. Upon next boot, I discovered both drives were missing from both Windows Explorer and Device Manager.

Later I discovered they were no longer detected by the BIOS, either. I already tried power off, disconnect IDE cable, boot, power off, reconnect IDE cable, boot. Nothing was detected for secondary master, and only some garbage appeared for secondary slave. Obviously, Win2000 fared no better.

This happened across a reboot and the drives were working fine since 9/2005, so I don't see how the IDE cable is a problem. The power supply is a Antec 550W, so I don't see how it could be from too little power or a crap power supply.

This was with a ABIT AV8 motherboard, Sony DVD-ROM+CD-RW combo drive, NEC DVD-RW/DL drive, and latest DT.

Copytrooper
24.07.2006, 11:47
Daemon Tools can NOT "nuke" any drives, so whatever reason causes your drives not being detected on BIOS level anymore, Daemon Tools has nothing to do with it.
Especially the "garbage" on secondary slave sounds either a defect cable, defect drive or mainboard/ide controller.