View Full Version : Cannot install from a mounted image

28.02.2003, 15:47
Hey there.

I really enjoy the speed and convenience of mounting CD images and running from the hard drive. Heretofore I haven't had any problems, but alas, finally I came across something I couldn't do.

After making an image of the Mechwarrior 4 Mercenaries CD (SafeDisc v1.50.020);
INSERT INTO `portal_posts_text` VALUES
which I'm 99.9682343% sure I did correctly, I tried mouting the image and installing from the hard drive. Unfortunately I get an error during the install process (it says a specific file is in use or corrupt) and halts. Safedisc emulation doesn't help. Burning the image to a CD allows it to work, but that defeats the point of keeping everything on the hard drive.

Its not a huge problem, but nonetheless I'm curious as to how this might be fixed incase it happens in the future.

Thank you for you time, I really find Daemon Tools to be a most excellent and useful program.

28.02.2003, 19:11
Is the file that it says is corrupt very long (long letter-wise)? I think it maybe could have to do with folder depth and limits and naming lengths. Just a guess though...

01.03.2003, 02:18
I don't think that is the case. The file is only seven or eight letters.

01.03.2003, 02:21
But how about the directories below. Are they very long. I ask this, because I recall another user(s) posting about this same problem a while back.

01.03.2003, 02:27
All directories, including the main install directory, are 8 letters or less and have no spaces.

Thank you for your quick responses by the way!

01.03.2003, 02:48
But what is total path length? fe: G:\test1\test23\kfdjsjfd\c\sdklfjdlksjf\sdjlfjdsf\ sdfljld\sdfjldfs\test.gif.

I have had problems sometimes installing visual studio .net, because some paths are longer than 255 chars.

You can also try this: Copy all the files from the image (using isobuster);
INSERT INTO `portal_posts_text` VALUES
to a directory on your harddrive, and install from there. I don't think you should run into copy checks during install, so it should install fine...

01.03.2003, 09:19
Thanks for your further help, but alas:

Total path length is much less than 255 characters

Copying the files from the image with isobuster and installing doesn't work. The installer generates a different error - that the .cab file that houses most of the files is corrupt. I think that is the copy protection breaking it, as the image is correct.

01.03.2003, 09:59
Some installers require being intsalled from a root drive (ie, X: vs C:\image).

I really can't think of what the problem could be.

01.03.2003, 20:28
I am 100% sure your image is broken. Try recreating it from other device.

03.03.2003, 22:40
Hmm! It seems you are right, it was broken after all. A new iteration works fine. I have no idea why it worked when burned, but alas, I don't really care.

Thank you both for your help.