View Full Version : Problems with USB CD drive when using daemon tools

02.03.2003, 00:02
OK, I've nailed the problem I'm having, and it's due to Daemon Tools (have version 3.29, tried also older 3.16 - same thing).

First, config that was used (well, the part that might be issue to this):
Leadtek K7nCR18D-Pro mobo
LG GCC-4320B combo drive in external USB2.0 box connected to onboard USB
Windows XP SP1

So, what's the problem:
When I boot WinXP, and turn USB CD drive on, it reckognizes it, I can read/write/etc .. all works superb. Than I turn it off (final result was same either if I just turned it off, or tried with 'safely remove hardware'). When I try to turn it on again - it won't reckognize it! I also get in 'Hardware devices' yellow asterisk on 'USB Mass Storage Device' and it says 'Windows cannot load the device driver for this hardware because a previous instance of the device driver is still in memory'.
However, if I uninstall deamon tools, reboot, all works OK (I can turn off/on USB CD as many times I want and it detects it/works flawlessly).
I've also tried to install USB2.0 drivers that were on Leadtek's site - but the result was the same as when using WIndows XP SP1 USB2.0 drivers.

Hope this 'bug' will be fixed soon! :)

Oh, yes... also, burning software - have only installed Nero (no imagedrive installed or any other 'virtual cd' program either).

02.03.2003, 00:23
Is the external cdrom the only cdrom/burner in your system?

My guess, is that there is a bug in windows. I think that windows won't unload drivers, because another cdrom (virtual cdrom) is still present.

I also had a problem where I had a cdrom installed with daemon tools. Then I put in a burner. On boot, I got a bsod, and had to reinstall daemon tools.

Basically, I think the problem is a result of adding/removing drives dynamically. Of course, venom might be able to provide a much better explanation...

02.03.2003, 11:48
Yes, it's onlt cdrom/burner in my system.

But.. problem, as said, only occurs when daemon-tools is installed. Even if I set number of devices to 0 under dameon-tools, problem remains.

Any chance you might be able to fix this?

02.03.2003, 12:00
Why do you have to unplug your cdrom? Is this really needed?

If you feel up to it, you could also try your external cdrom with daemon tools on a different os and different computer to see what happens.

02.03.2003, 16:51
I have USB CDROMs connected to USB1.1 and USB2.0 hubs and can turn on/off them many times (XP SP1). Be sure - this feature was tested many times in Daemon and is of very high priority. Maybe the issue with some other software. Please post what drivers are loaded for your USB CDROM in device manager (in properties).