View Full Version : Daemon-Tools doesn't load in rare cases

13.03.2003, 00:19
Just want to tell you that daemon-tools isn't loadet on my system in rare cases (approx. 2 times from 100). It doesn't even work if I want to start it manually and have to reboot if I need it.

The post is just for information, no complain of anything.

My system specs:
P 4 1,8 Ghz
G-Force 2 MX 220
256 MB SD-Ram


Windows XP SP1 with nearly all updates

If you think you know the reason or nead more information just post here and I will help.

13.03.2003, 00:58
What errors do you receive? How doesn't it work? Do you mean it doesn't mount images properly or tray icon doesn't work?

13.03.2003, 10:45
No, there is no error, there is simply no icon and you can't start it by clicking on the daemon.exe.

Strange, isn't it?

13.03.2003, 13:12
I recall something like this a long time ago...

When it doesn't load, verify this by checking in task manager (ctrl+alt+del). You are looking for daemon.exe. Also, try running a 3rd party addon (daemount, daemonui, etc...) when this happens, and see if the addon works.

Finally, try running C:\program files\d-tools\daemon.exe (if you look in the registry, -1033 is added for language settings) when you can't launch daemon tools.

13.03.2003, 13:17
Its not worth the work, it happens very rarely and I just need to reboot my PC to work again. I just wantet to mention it that it could be fixed in future versions.

Allen Dawkins
19.03.2003, 16:44
I have this exact problem right now. When I click on the Daemon Tools ICON, nothing happens. Also I can't even find the .exe file. I would appreciate any help I can get.

19.03.2003, 20:24
First, please post your os version, any burning software installed, and any other info that might help.

You say you have the exact same problem? From what you say about not finding the .exe (it should be in C:\program files\d-tools) it seems as if your problem happens always, not rarely. Please confirm or deny this.

Have you tried reinstalling? Do you get any error messages?

19.03.2003, 22:18
If it helps I have windows XP with all updates installed and following burning software (all latest version):

Clone CD

19.03.2003, 22:42
@player1: I was refering to Allen Dawkins

19.03.2003, 22:51
I know, but If you compare my settings and his maybe you can see which program affects this problem

Allen Dawkins
19.03.2003, 23:11
Thanks. To recap again, when I installed Daemon Tools it creates the ICON and when I click on the ICON nothing happens. This happens every time and I've yet to get it to work. I looked in the directory (D-Tools) to run directly from the .exe file and it'sot there!

Currently I'm running is Windows XP. I've removed Daemon tools and reloaded and rebooted several times without success. My computer is only a couple of months old and the only burning software on it was Roxia Easy Step. I removed that when I understood that Daemon Tools would not work with that particular software on the computer.

Any help would be appreciated.

19.03.2003, 23:47
Launch device manager (start, run, devmgmt.msc)
Navigate to scsi and check if st3??? is present (and working)
Navigate to system and check if pnp bios extension is present (and working)

This error has never been reported afaik and it seems very odd to me. Can you try insstalling daemonscript (prog in my signature) and see if you can launch it?

Allen Dawkins
20.03.2003, 04:57
All, my problem has been resolved. I'm running Windows XP. When I installed Daemon Tools it placed an ICON on my desktop but also one at the bottom right of the screen. I was able to load the virtual drive from that ICON and then to burn my CD. Thanks!!

20.03.2003, 08:03
Oh, my god.;-)

30.03.2003, 23:05
I'm having the same problem with my machine as described in the first post but it is most of the time rather than rarely. I am running XP Pro, Nero, pinnacle instant copy, etc. I have installed the latest version 3.32 (I was using an older version and had the same problem) but I am still having the same problem. When it does work it seems to work great and I can mount/unmount from my system tray icon just fine. Most times however I do not get a system tray icon. I have tried to open the program by clicking on the desktop icon which seems to do nothing; I have also tried to launch daemon.exe from the d-tools folder with no luck. I did just boot my machine and once again daemon tools didn't launch, at least not that I had a system tray icon anyway. I did check my task manager and found cidaemon.exe loaded twice, as well as daemon.exe. I then ran your command from your previous post (Andareed) and bingo it launched! I can get by with this work around but do you have any ideas as to why this might be happening?
Much appreciated,

08.04.2003, 19:58
OK I spoke too soon. It isn't loading again and if I run the exe command it still doesn't load, must've been a fluke. It will eventually load hower if I restart my pc over and over again until it launches, sometimes once sometimes 10 times. I don't get it?

08.04.2003, 20:30
Can you try a 3rd party frontend (daemonui, daemount) or daemonscript (see my sig) and see if you are able to mount/unmount etc...?

14.04.2003, 14:15
First of all, I'm sorry for my poor english. I don't live in english world. But I want to inform my experience.

I'm having the same problem as mentioned above. Sure, I have attempted to give the most method as possible as i can, but it did not work.

But, I note that it work properly if windows log off and then re-logon.
that is, Booting the system and windows is ready (at this time, Daemon tray icon is invisible);
INSERT INTO `portal_posts_text` VALUES
and just windows log off and log in again. Now, Daemon tray icon is visible. At least, my system always is.

for reference, briefly my system info is...
AMD AthlonXP 1800+ / 512MB SDRAM
Windows XP SP1a / MS Internet Explorer 6 SP1
Daemon-tools 3.29 -> 3.32 / Nero / Alcohol / BlindWrite / EasyCD 5 and so on...

again sorry for my sick english, wrong expressions... :oops:

14.04.2003, 17:45
So, when windows boots up, running daemon tools does not work. But if you logoff, then logon, daemon tools works?

btw, your english is not bad, and we understand not everyone speaks engish :lol:

26.04.2003, 15:59
After my initial postings I began having problems with microsoft office xp, lock ups in outlook etc. I dumped and then reinstalled office and still had the same problems. Anyway I threw in the towel and did a complete format and reinstall and now everything is happy, including Daemon Tools. Sorry I can't provide more insight as to what the problem was but I'm using all of the same software as before and it works fine now. I believe it may have been a corrupted file in windows or office. At least for my situation I think we can rule out a bug in Daemon Tools.