PDA

View Full Version : uninstalled daemon tools now CD & DVD drives don't work



thegriffgeeks
21.11.2005, 00:17
This rots. I installed the newest version of the tools. It installed just fine. Everything worked, but I decided not to use it. So I uninstalled. It uninstalled with no problems. Now I have no CD or DVD drive. In the hardware manager they have the exclamation points next to them with this message "Windows successfully loaded the device driver for this hardware but cannot find the hardware device. (Code 41)"

I read the manual uninstall instructions, and found that all Daemon tool stuff had been uninstalled. I uninstalled the drives from the device manager but to no avail!!! I tried to restore back to before I installed this tool, but that hangs.

I am running XP with SP2.

What is the fix!! I'm dead in the water!! :mad:

kernel32
21.11.2005, 15:30
Same problem here, I found no pnp bios extention, the scsi i did found and i uninstalled it. Same goes for anti-blaxx and deamon tools but now i do not have any cd-rom no real ones, no virtual. I get the same error code and a yellow exclamationmark with my dvd-rom

thegriffgeeks
22.11.2005, 01:51
Amazingly enough Microsoft was useful.

This article had the fix. I am back up and running.

http://support.microsoft.com/default.aspx?scid=kb;%5BLN%5D;q314060

Underheaven
22.11.2005, 05:10
thegriffgeeks, you could try reinstalling Service Pack 2, that usually fixes broken catalog files.

And both of you guys should check C:\Windows\setupapi.log and upload it somewhere on the web if possible.

buppelupp
22.11.2005, 09:12
I had the same problem as you're having now.. My burning software stopped working, and the problem seemed to somehow be driver related.. So I tried to uninstall _everything_ that had to do with Daemon Tools and STPD + removed cd rom devices so they would reinstall after reboot. However, I kept being asked to install unsigned drivers for the CD-roms and the IDE Controller driver was also messed up. Exclamation marks beside the drives and also experienced problems with Primary and Secondary IDE channel when trying to revert to the correct IDE Controller.

According to others in this forum, DT4 shouldn't ask you to install unsigned drivers, but it did for me, and I suspect it is somehow related to DT4 tampering with the IDE Controller, which in turn makes Windows identify the CD-rom drives on the Secondary IDE Channel differently. Just an intuitive guess.

So I ended up with reinstalling windows XP... don't mean to be discouraging,.. but I really spent ages trying to fix this.. And I'm not going anywhere near DT4 before an update version fixing the most serious issues has been released. It's a great program, but V4 was a dodgy experience from start to beginning for me.. had several other errors as well concerning open handles etc.

Underheaven
23.11.2005, 07:02
This is a double post. But I think its really relevant because there are so many posts on this issue its hard to keep track. I replied to your last post at this link (http://www.daemon-tools.cc/dtcc/showthread.php?p=36538#post36538).