View Full Version : device setup error: code 25032

02.04.2003, 08:50
When i was first installing the DT, it displays a message of "device setup error: code 25032".So does anyone knows what the problem is?

Thx for your help~~!

02.04.2003, 11:35
What is your OS?

04.07.2003, 18:44
oh,god ,ive exactly the same error with him,when i try to install dt,it displays :
Error 25001. Device setup error:code 25032(0x61c8)
contact your support personnel.
how to solve the problem? my os is windows me.
i have even reinstalled my os,but it still doesnt work.help!! :cry:

06.07.2003, 19:45
When you get this error - do you see something in device manager before pressing ok? Any exclamation marks etc.

06.07.2003, 20:05
oh,there is a unknown device in the device manager.I just found it,
it came out because of the dt?i tried to search the device drive,but cant find a right one.is it due to the error? help me out !thx a lot!

07.07.2003, 08:55
So delete it. reboot and rerun setup.

07.07.2003, 19:19
i deleted the unknown device and restarted then try to reinstall dt as u said ,but the error message still came out :cry: ,whats the problem?

07.07.2003, 20:34
What is displayed in DM for the device with error? What is your OS?
More details please.

07.07.2003, 23:05
There is a unknown device in the device manager,it displays as a normal unknown device(cant find a right drive programm for it) ,it locates in the device manager under the folder of computer-->system device-->unknown device.
After i had deleted the unknown device ,i rebooted and tried to reinstall dt,the error msg poped up: Error 25001. Device setup error:code 25032(0x61c8)
contact your support personnel.
Then i had to terminate the installation,and checked the device manager
,the unknown device came out again.
By the way my os is windows me.

06.08.2003, 14:31
i have this same problem but tell me first what is device manager and if it is that place where are all those drivers and stuff then i dont have any of those yellow question marks there.. :?

06.08.2003, 14:37
i dont have any unknown devices in device manager but that error still comes. so what's the problem and btw my OS is windows 98 SE

07.08.2003, 04:08
I have the same Problem as well. I do have some unknown devices in my Device Manager. When i uninstall them, they keep coming back by the next restart. My OS ist Windows XP Home Edition. I really would like DT to work. Whats the Problem with it?

08.08.2003, 12:03
So is there an answer to this Problem or do i have to wait for the next version of DT?

BTW: My OS is Windows XP Home Edition. I also have Nero burnung Rom Software on my PC. I have no other Mount or Emulation Progs on my Computer.

10.08.2003, 23:20
Please mail me to venom386@daemon-tools.cc to discuss this problem.

11.08.2003, 12:30
Ok, when i write to that email my program tells me that there a delivery failure as if the adress wouldn't exist???

11.08.2003, 12:50
Sorry, use venom386@daemon-tools.cc!

11.08.2003, 16:08
Yes, i corrected the address. Sorry.

15.08.2003, 00:59
Everytime i write to that adress, my mail program tells me i have a delivery failure because the adress doesn'T exist? Are u guys kidding me or what?

15.08.2003, 01:24
No, we are not kidding, venom386@daemon-tools.cc is the correct adress.

Please try again, it's possible that it was a temp-problem (yesterday great networkareas in germany got trouble because of traffic-load)

04.10.2003, 01:46
Operating System: Windows Me
Burning Software: none
Anti-virus Software: mcafee v7.02 updated
DAEMON Tools Version: 3.41

I had the same problem.
I installed dtools 3.41 over 3.16(without uninstalling it)
when installing, near the end
"Device setup error: code 25032(0x31C8)
I got too an unknown device, tried deleting it(the device) and running the repair from the setup, but exactly same problem comes
Im gona try an older version(had no probs with 3.16)
Added info: installed 3.32 and everything is ok

04.10.2003, 12:37
Before you press ok, please watch in the device manager - what unknown device you have and its status?

05.10.2003, 08:21
Operating System: Windows 98 SE
Burning Software: Easy CD creator (uninstalled thoroughly)
feurio, CloneCD
Anti-virus Software: AntiVir
DAEMON Tools Version: 3.41

Installation terminates with error codes 25001 and 25032. After installing again virutal SCSI driver cannot be found.
In the device manager there are two unknown devices in folder computer-->system device-->unknown device. Removing them and reinstalling dt does not help.
Used feurio to detect driver conflicts and installed new Aspi driver: does not help either.
Same problem with Alcohol120.

05.10.2003, 22:23
ASPI driver is irrelevant for Daemon/Alcohol absolutely, they don't need it.
Delete all unknown devices and reboot. Then try to run setup - when you get 25032 - DON'T do anything! Immediately go to device manager and check what is there and with what status.

06.10.2003, 08:01
Directly after error code 25032 (0x61C8)
(0x0) there is only one unknown device (with exclamation mark) and the status is: no drivers installed (Code 28).

06.10.2003, 12:11
You have smth either with antivirus (try to disable it) or Windows file protection. Do you see pnpshark.inf in the WINDOWS\INF folder?

11.10.2003, 13:04
Sorry, AntiVir doesn't seem to be the cause/curse and no pnpshark in windows/inf.

11.10.2003, 20:14
3.41 setup copies this file to Windows\inf folder. Check it good BEFORE you press ok after error (after you press ok setup will rollback and delete it).
If you still not see it - then problem is with Windows file protection.
Addition: as you use 98 then file protection has nothing to do here (it is in ME only)
in this case i have no idea what's going on.

12.10.2003, 09:04
Before pressing Ok, pnpshark is there, indeed

12.10.2003, 20:18
Do you see the dialog of Windows rebuilding driver list during installation?

13.10.2003, 06:53

13.10.2003, 07:35
After you get error and before pressing ok, please check what
is in registry at 'HKLM\Enum\Root\PnpSharkEnum341' key - show me all values present there. When you see in device manager some unknown device please aslo check 'PnP BIOS Extension' device if it is present, its driver and status.
Before running setup again - please make sure the above key isn't present and there are no unknown devices in device manager.

13.10.2003, 09:05
Registry: HKLM\Enum\Root\PnpSharkEnum341
Standard: "no value"
Registry: HKLM\Enum\Root\PnpSharkEnum341\000
Standard: "no value"
Capabilities: "14 00 00 00"
Class: "Unknown"
ClassGUID: "{4D36E97DC32511CEBFC108002BE10318}"
ConfigFlag: "40 00 00 00"
DiviceDesc: "Unknown Device"

There is again a an unknown device in the device manager but no 'PNP BIOS Extension'

23.10.2003, 11:19
P.S. when trying to install PnP Bios extension I get a rundll32 error. Sounds to me like I should get rid of Win98 asap. What do you think ?

Any help would be appreciated very much !

26.10.2003, 13:15
Are you sure there are only 3 zeros after 'HKLM\Enum\Root\PnpSharkEnum341\'?

26.10.2003, 17:44
I updated to Win ME. Daemon tools works fine now.
And now there are 4 zeros after 'HKLM\Enum\Root\PnpSharkEnum341\'?
Thanks for the help !

15.11.2003, 03:43
Operating System: Windows XP Pro SP1
Burning Software: Nero 5
Anti-virus Software: NAV 2004
DAEMON Tools Version: 3.41

I have the same problem.
When installing, near the end
"Device setup error: code 25017(0x61B9)
There are no unknown devices in my Device Manager. So what to do?