PDA

View Full Version : Can't open Alcohol (mdf/mds) image



SergeyUser
14.12.2005, 05:28
Hello, Support team,

I would like to report a potential bug:
It looks like Alcohol images created with DPM option are not working (images without this option do work (in a sense that Daemon Tools mounts this image without an error)). On such image mount attempt, Daemon Tools reports the following error:
Unable to mount image. Invalid image file. But Alcohol mounts this image without a problem.

Environment details:
Windows XP SP2 (build 2600) Russian
Alcohol 120% 1.9.5.3105
Daemon Tools 4.00HE

Original disk details:
Appears to be protected with StarForce 3.14.02.648 (as of per A-Ray tool)
Also contains a huge amount of bad sectors (400+ Mb)

Is it a known issue? Let me know if additional help is required to reproduce. I'm really interested to run this image with Daemon Tools (Alcohol appears to be black-listed by the target program).

Development
15.12.2005, 04:52
Please specify the names of games which are affected.

SergeyUser
15.12.2005, 14:12
It is not a game but educational software. I have sent you details of the software by e-mail.

KilledNoob
18.12.2005, 11:14
DaemonTools doesn't like dots . underlines _ and the like, as Mystique noted here (http://www.daemon-tools.cc/dtcc/showthread.php?t=7522) It also fails if the name of the directory the image is in contains these - for me copying and renaming the image worked

SergeyUser
18.12.2005, 23:46
I carefully removed all dots, underlines and spaces from directory and file names, and can confidently confirm that the problem remains.

EpicDark
19.12.2005, 02:13
I had this same kind of problem when mounting a game. When I tried to mount the mds file, it said "Unable to Mount Image". I then told it to show all files and tried to mount the mdf file. Everything worked just fine.

Development
19.12.2005, 03:28
Where did you send your email?

SergeyUser
19.12.2005, 10:45
I have sent it using forum e-mailing feature (Send e-mail to VeNoM386, from popup menu for user name (VeNoM386))

LocutusofBorg
19.12.2005, 18:13
please resend the email, using this email-adress:

locutus@daemon-tools.cc

in case of attachments you MUST use .rar-archive, other-
wise the attachment will be deleted!

SergeyUser
20.12.2005, 04:30
First of all, the reason EpicDark highligted above is the case for me: I was able to mount the image through MDF file (instead of MDS file which DT shows under 'All images' filter). So I would suggest to improve error message at least, as it is not really clear at the moment.

Finally, I was able to see the image mounted, but with no success in running this particular software (it still shows 'No CD' error; Given StarForce 3.14.02.648, I used SF Nightmare to disable my real CD, but again with no success). This, I think, is a separate subject and I will create a separate thread to discuss. But before closing this support thread, I would like to ask for additional question, which is the first step for me to troubleshoot the 'No CD' problem:
Is there a way to identify that my mounted image actually contains RMPS information, AND that this information is actually in use? I don't know how to do this (possibly, there is some debug feature?) - DT doesn't show any indication. So I can validate at first sight the image I have created and then go to more specific problems linked to this particular CD/protection.

P.S.: LocutusofBorg, I have sent details of the software to the e-mail locutus@daemon-tools.cc. I guess you may have a different level of interest in troubleshooting this software-specific problem, but anyway.