View Full Version : Unable to add adapter. Invalid parameter.

18.12.2005, 17:18
Hey guys,

I successfully installed DT4 and it worked great until I had to repair windows for a different reason.

When installation was complete however, I had system file error within DT4. So I searched device manager under hidden and uninstalled a couple of items that had a yellow exclaimation mark. Now I get "Unable to add adapter. Invalid parameter."

I have tried many things and now getting very frustated. I do not believe its a Daemon tools fault, it sounds like I have done something to windows. Maybe you guys can help me.

I can confirm that a fresh install works as I did a 2nd install, but I do not want to format my main OS. Maybe I can copy some settings from my other OS??

Any one got any ideas?

I am running Windows x64 if that's any use.

18.12.2005, 19:03
Finally! I have sorted the problem!

I installed DT4 on my 2nd OS, then I exported the registry entry HKLM/system/CCS/services/SPTD and rebooted.

Then it came up with "file system error" so I rebooted in safe mode, hit ESC during boot up and reinstalled DT4. I had abort/rety/ignore on install, but I ignored them all and it continued.

I now have DT4 working ;)

Hope this helps with others posts listed.