PDA

View Full Version : Can mount images, but not run the setup files.



Ripperjack
22.05.2003, 01:01
I've hit upon a real strange problem and I have no idea on what to do...

It appears that I can create a CD image, with either BlindWrite 4.4b, Clone CD 4.2.0.2 or ******** 3.0, which can be mounted within Daemon-Tools 3.33

When the image is mounted I can view all the files on the virtual drive, and copy them to another folder on my machine. However if I try to run an executable, setup.exe for example, the file fails to run. When the file does fail I get one of a variety of error messages. So far I've seen error messages like;

- File not found, setup.exe
- ikernel32.exe failed to execute
- unable to execute setup.exe

The twist is, if I mount the image and then copy all the files from the virtual CD to a folder on my hard disk, I can run the installation files normally. Also, if I have that very same disk mounted, despite the fact that no .EXE can run from the disk, the virtual image is still counted valid for CD checks and the game will run normally ( after copying the install files to a different location and installing from there ).

Since I have a second machine on my network I tried mounting an image on that machine. I've found that I can mount the image with Daemon-Tools, and then with a mapped drive install across the network without any issues. So it appears that the problem machine, is the only one that is having this issue.

I have tried a total removal and re-install of Daemon-Tools, full virus scan ( came up clean );
INSERT INTO `portal_posts_text` VALUES
disk defrag and Windows 2000 repair install, but nothing appears to work. I fear that only a total rebuild has an hope of fixing this problem. :?

Is there anything else that I could do that might fix the problem, without resorting to that old DOS mantra "Format C:"? :(

Development
22.05.2003, 19:59
Uninstall your antivirus prog completely and check.

Ripperjack
24.05.2003, 06:23
Thanks for the suggestion but that didn't appear to have any effect. I currently use AGV 6.0 Free Edition, of which I totally uninstalled. Then I used System Mechanic to run though the registry to make sure all references to AGV were gone.

However, the problem remains.

I even created a new image for the game Vietcong, of which I just purchased, and that image too fails to run "setup.exe" without launching an error. Mounting the image after clicking away the error messages, however, will still allow me to run the game after it was installed with the CD's.

I fear that something more fundamental with my install of Win 2000 SP-3 has gone wrong, and I'll guess I'll have to rebuild the system. :cry:

Andareed
25.05.2003, 00:51
Try burning calc.exe to a cdrw and try running that :)

Ripperjack
02.06.2003, 07:33
Sorry for not getting back to you sooner. I am in the process of building a new machine, and it's taking far longer than I thought.

Anyway, I was checking over the software to install on my new rig, when I remembered something that might be the cause of the problems I'm having with my current computer.

The day before I noticed this strange writing problem surfaced, I installed ******** 3.0 :!: During the installation process the GJ installer, installed a device called a universal SCSI adapter.

I think what happened was since the Daemon Tools device was already installed, there was a problem installing the ******** device, causing this strange behaviour in Daemon Tools.

I've yet to uninstall ******** to confirm this, so I'll guess I'll nuke my copy of ******** and see if Daemon Tools comes good again.

If this IS INDEED the cause of my recent problems, then I'll have to run ******** and Daemon Tools on separate computers. Thank gawd for my small, 3 PC home network. 8)