PDA

View Full Version : Problems with setting default drive letters



brianmbruce
06.06.2003, 12:08
Hi,
I'm running Daemon tools on our school network and i'm having problems setting default drive letters for daemon tools. I've been installing daemon tools and setting the virtual CD drive letter to H:\ . This works fine but i've been building RIS images(Microsofts version on Norton Ghost effectively). The image works fine but after rebuilding a machine with the RIS image Daemon Tools grabs the next free drive letter (usually e: but sometimes F: ) rather than using the pre-defined H: drive which i set as part of the RIS image. I've been using scripts for users to run multimedia so i need to set which drive letter will be used for the virtual cd drive. is there anyway to set this so it stays?

Brian Bruce
Robert Gordon's College
Scotland

Development
08.06.2003, 08:33
The letter assigned should stay unless it is occupied after reboot by some HDD or other device etc. When you set drive as H: and reboot - it is still H:?

brianmbruce
09.06.2003, 08:54
Hi,
Yeah. If after rebuilding a PC with a RIS image (at which point it picks the 1st free drive letter) I manually set the drive and reboot the PC then the drive letter sticks permanently :)
Unfortuantely I've got to re-install and set up 500 PC's this summer and having to do this on each one manually could take a while :?

brianmbruce
09.06.2003, 09:09
:arrow: Just a coupe of points i should have mentioned in my last message. I've tried rebuilding the the RIS image on the same machine that I imaged it on with the same hardware configuration (drives,ect.) and it still grabbed the 1st free drive letter (e:) instead of the previously set H: so it could be something to do with act of rebuilding it with a RIS image.
Is there a setting in the registry or in the daemon tools directory that controls which letter daemon tools uses. If I knew which setting it used I might be able to create an MSI package to set it. I've tried this already changing the setting in daemon tools manually as an MSI but the package failed with a registry error. I can remember the exact error but it was trying to change a DOS level drive setting and didnt have permission to do so (even as an administrator). I'm using windows XP with SP1 installed btw.

Development
09.06.2003, 13:32
Try to use some 3rd party tools on our site - they can automate the task of setting drive letter via calls to daemon.dll.
Drive letter assignment is stored in registry database of mount point manager - you should never try to change it manually!