PDA

View Full Version : Daemon no longer works =(



gopherman
09.06.2003, 16:19
Here's my situation...

I was using Daemon Tools (v 2.88 ) for a single virtual drive, and everything was working fine. One day I decided I wanted more than 1 virtual CD drive, so I tried to do so by right-clicking on the DT icon in the system tray. I set it up for 4 drives (the more the merrier, righ?);
INSERT INTO `portal_posts_text` VALUES
but unfortunately none of the addition drives showed up in Explorer, although the original virtual drive still remained.

I checked Disk Manager, and the extra drives didn't show up there either. So I got the bright idea to move to a newer version of DT; maybe that would let me use more than 1 virtual drive. So I uninstalled Daemon 2.88, and tried to install 3.33, but I got the following error message during installation:

"Error 25001. Device setup error: code 25012 (0x61B4);
INSERT INTO `portal_posts_text` VALUES
88 (0x57).
Contact your support personnel"

After numerous attempts to install it, I gave up and reinstalled version 2.88, and to my suprise, it didn't work anymore. It installed OK, but now neither Explorer nor Disk Manager recognized any of the virtual drives (whereas previously they wouldn't recognize any beyond the first one).

The drives, along with the virtual SCSI controller, show up ok in the Device Manager, but they don't show up as volumes in either Disk Manager or Explorer. If I view the properties of the virtual drives in Device Manager, and click on the "Volumes" tab, and then click "populate", I get the following message:

"Volume information for this disk cannot be found. This may happen if the disk is a 1394 or USB device on a Windows 2000 machine."

So now neither Daemon 2.88 nor 3.33 will work, but the problems don't end there. I tried installing nearly every other version of Daemon in the archive here, and they all either have the same problem as 2.88 or the same problem as 3.33. As if that weren't bad enough, I've tried installing several other virtual CD programs (Alcohol, Fantom, Virtual Drive, and about a half dozen others);
INSERT INTO `portal_posts_text` VALUES
and now none of those work either! Some of them (Alcohol & Fantom) give me the same error message I got with Daemon 3.33, and some give me the same problem as 2.88, with Windows not seeing the virtual drives (they still show up in device manager).

One thing that might be relevant is that I am using a RAID 0 volume as my main hard drive, with an on-board Promise controller, the driver for which shows up under RAID-SCSI controllers in the Device Manager.

One more reboot and I'll go insane. The only thing left to do is reformat/reinstall, but that's like using a guillotine to cure a headache. All I wanted to do was have more than 1 virtual drive.

Thanks in advance to anyone who can help.

Development
11.06.2003, 23:16
Something is really bad with PnP abilities of your system. Hard to say what is the cause. In any case i will try to investigate that. Do you use
Windows 2000 SP3?

gopherman
12.06.2003, 05:59
Nah, XP Pro. I bit the bullet and reinstalled XP (by installing it over the current installation);
INSERT INTO `portal_posts_text` VALUES
and that did the trick. I reinstalled DT 2.88 (I'm not going near 3.33 again);
INSERT INTO `portal_posts_text` VALUES
and it works now, all 4 virtual drives show up. No idea why it stopped working, but all is good now.