PDA

View Full Version : Unable to use Daemon Tools anymore



switch
17.01.2006, 12:00
At the moment I am unable to use Daemon Tools on my ssytem after having absolutely no problems with it for half a year. Not even StarForce protection drivers seemed to cause problems.

Recently I've tried installing a game from an image. At some point during the installation I had to switch CDs. I tried mounting the new image on the same drive as the first and got an error, something about "very strong protection" with retry/ignore options. Retry didn't do much except cause my system to hang. I had to hit the reset button. I tried again, this time using a second virtual drive for the installation. It hung my system yet again. The third time I hit the 'Ignore' button - same effect: my system would hang. Only this time, after restarting, Windows would NOT boot. It didn't take me long to figure out that the system would 'hang' during startus just as it was loading the SPTD.SYS driver (thank god for the "Press ESC to stop loading...).

Now I am running with the SPTD.SYS file renamed to something else and I cannot install or uninstall daemon. I've tried downloading the stand alone SPTD package and using it to remove that driver but when I run it with the remove option it just says that the driver is not installed. I cannot uninstall Daemon Tools either ("Unable to validate installation"), and if I try to reinstall it, it requires a reboot (after installing the SPTD driver I guess) and this causes my system to hang again. I need to rename the new SPTD.SYS file in order to be able to use windows again.

I've tried looking over common problems and solutions forum and nothing there helped me. As a sidenote, the game whose installation cause the problem was Indigo Prophecy and I've never experienced any BSOD for quite a while.

I hope you can help me with this issue. Thank you for your time!

VincentL
19.01.2006, 01:08
Hello,

Read and try this (http://www.daemon-tools.cc/dtcc/showthread.php?p=45859#post45859) ;)

switch
19.01.2006, 13:20
That is one of the many solutions recommended on this forum that I have tried. No sollution worked for me, that's why I resorted to posting here :( I really don't want to have to reinstall my system just for this one issue.

VincentL
19.01.2006, 15:46
Do you mean you are not able to uninstall completely Daemon Tools, even with restarting in debug or safe mode and renaming the DT sys file ?

switch
19.01.2006, 21:47
Technically yes. I am unable to uninstall the software, even with the whole restart in safe/w debug and renaming bit. Also I cannot get my system to run with the SPTD.SYS driver - therefore I can't re-install since any installation requires to install the SPTD driver and have the system restarted, which for me would mean being totally unable to boot up.

papasmurf
19.01.2006, 23:07
Yeah same problem... But my PC crashes if I start it in debug mode though, sup?!

VincentL
20.01.2006, 08:21
Also I cannot get my system to run with the SPTD.SYS driverJust try to rename SPTD.SYS in whatever you want, you would then be able to boot your system...

switch
20.01.2006, 14:27
Just try to rename SPTD.SYS in whatever you want, you would then be able to boot your system...
That's how I'm running the system, d'uh! However that still doesn't help me, since I cannot use Daemon Tools!. Any suggestions that might help me to get it working again?

VincentL
20.01.2006, 16:14
Uninstall it completely like I did (http://www.daemon-tools.cc/dtcc/showthread.php?p=45859#post45859), additionally maybe you will have to uninstall SPTD device in your Device Manager in the Control Panel :confused: Does it work ?

You know, I almost had the same problem and as long as you do not have DT + SPTD fully uninstalled, you will not be able to do a fresh install...

switch
20.01.2006, 16:19
Uninstall it completely like I did, additionally maybe you will have to uninstall SPTD device in your Device Manager in the Control Panel Does it work ?
That is the first thing I ever tried and it did NOT work. It wouldn't uninstall. I finally used regedit to search for reference to daemon tools and sptd in order to completely uninstall the system. Merly the few steps in that post you keep linking to is not enough. At least wasn't in my case.


Anyway...

Reinstalled my system. THis time I figured exactly what the problewm is. I have a game called Indigo Prophecy. Comes on 3 CDs. There is no problem while installing from the CDs. If, however, I try to make backup copies (either with Alcohol 120, UltraISO or CloneDVD), I have a problem while using them to install the game.

Here's what I did, with both Daemon Tools 4.03 and DT 3.47:
1. Mount 1st CD image (made with either of the softwares mentioned above).
2. Install
3. When asked for 2nd disk, mount 2nd CD image on any virtual drive (could be the one used for the 1st CD or any other)
4. Press OK on the Installation's "Insert Disk 2" prompt.

At this point, the install no longer continues (no disk activity at all, no progresss after 20 minutes - first part took roughly 60 seconds with intense HDD activity). Daemon Tools becomes totally unresponsive and trying to Cancel the installation causes Explorer and Daemon Tools to become totally unresponsive (even after half an hour). They cannot be closed via Task Manager either. Also the system refuses to reboot/shut down if the option from the Task Manager is used. Only solution is the power cord/reset button.

After the restart, the system will NOT boot, unless I disable the SPTD or D347*** driver. In order to reinstall Daemon tools again, I have to manually track down and disable any reference to these drivers in the registry.

I'd also like to mention the method of manually disabling the dt347*** or SPTD (I'm talking about the actual registry keys that need to be deleted, not the general stuff everyone can read and point out) drivers is not detailed anywhere on your upport forum, or is extremely difficult to find.

switch
28.01.2006, 18:56
Have you read the posts entitled "How to remove DAEMON Tools V4" and "My system won't boot after installation of v4, or problems with SPTD.SYS" in the Common Problems and Solutions forum?

I want to uninstall DT 4.0 after recent problems with the SPTD driver and I've been TOTALLY unable to. I feel I must say that NO SOLLUTIONS OFFERED BY THIS FORUM HELPED. The two you mentioned above were the obvious first choices but none of them helped. I've also tried a few methods suggested by other members of this community (one 'VincentL' I think, among others) - to no success. I am forced to keep the software installed with the SPTD.SYS file renamed just so that my computer boots. I can't get rid of DT or the SPTD driver so that I may install it again - or install some software that is stable for a change.

Black Hawk
01.12.2008, 11:55
I have installed battlefield 2 but i dont have a virtual disc were can I get it:confused:

Blazkowicz
01.12.2008, 13:00
You create it by yourself using DT Pro and your original disc.