PDA

View Full Version : Problems with RMPS-Emulation



AbatC
11.06.2003, 11:17
Hi,

I have some major problems with RMPS-Emulation, both in Daemon-Tools (3.33) and also in Alcohol 120%.

For example i made a copy of Anno 1503. When I turn on RMPS and start the game the copy-protection will be bypassed, but as soon as the intro video should appear the system freezes completely (mouse cannot be moved, no bsod). When i try to read data from the CD (with RMPS enabled) the system freezes the same way. When i disable RMPS all data can be read, but the game will of course not start. This happens on all CD/DVD-Drives installed.

I have also tested Vietcong and NOLF 2. Same problem (Vietcong will actually run with full install, as the game then checks only copy-protection but does not read any data from CD!)

The CD's work on any other computer i tested.

I have also made a clean install of Windows XP pro SP1, with no additional software or drivers installed. Here it happens again.

My system:

Asus P4PE with 1GB Ram /with GB lan
Intel P4 3.06HT
Radeon 9700pro
Soundblaster live 5.1
Adaptec 2940uw
Plextor 40tsi
Toshiba 1401
Plexwriter 1210S
Windows XP pro SP1


The Onboard-Sound is disabled, i also tried to deactivate any device not necessary. The problem stays.

The Alcohol Forum was not very helpful on this instance, they only told me something about 'incompatible software', what should not be a point after a complete reinstall of the OS...

Any idea??

Andareed
11.06.2003, 14:52
Do you have an image of the games you made? Are you able to make a new rmps image of the originals? Have you tried different cdroms?

AbatC
11.06.2003, 15:16
Answers:

1) I have the images on hard-disk. They work (as RMPS must not be enabled for them)

2) Yes, i can make new rmps, as i have the original CD's here...and they work of course, as they do not need emulation.

3) I have tried every drive in my PC (Plextor 40Tsi, Toshiba 1401DVD, Plexwriter 1210S). All the same. Freeze

As i said above the copied CD work, but not on my PC. My secondary (backup PC) with Windows 98se and Liteon 52x CD-Rom runs the CD perfectly with RMPS, also a friends PC with nearly the same hardware as mine works perfectly...only difference in hardware is the CPU (mine P4 3.06HT, friend Celeron 2000) and the graphics-card (mine Radeon 9700pro, friend Geforce 4 4200). Mainboard / RAM / Soundcard / SCSI-Controller are absolut the same, he even got the same burner (Plexwriter 1210S);
INSERT INTO `portal_posts_text` VALUES
both systems use Windows XP pro SP1. On his PC the CD works, on mine not...

I'm now rather helpless...

Development
11.06.2003, 23:35
Do these games work just when mounted in virtual drives (same images that you have on HDD)? No freeze?
Try to dump from any physical CD-R (when RMPS is enabled of course) and check what happens. No freeze and no errors?

AbatC
12.06.2003, 10:10
Hi VeNoM386,

i didnot get your point, so in short terms:

I put the original CD in CD. Dump the CD with Alcohol 120% to image (with DPM Information).

When i use the image with Daemon-Tools (or Alcohol Virtual Drive) it works.

When I burn the CD i tell Alcohol to write RMPS-Data on CD. This CD won't run (the RMPS data can be read correctly from CD and the games start, the 'normal' data cannot be read from CD as long as RMPS Emulation is enabled so the system freezes when the games read the data).

As I said before the copied CD's work in other PC's, so i connected my CD-Drives to my (old) backup PC. The images all work perfect, so it seems its a problem with my system...

Tonight i will check if i can dump the copied CD, update tomorrow.

May there be any trouble with a hyper-threading CPU ???

Development
12.06.2003, 18:36
I am not sure about hyperthreading - don't have such CPU.
My point was to see what happen if you just read or dump from physical CD-R with any other program (not game)

AbatC
13.06.2003, 09:53
New Update:

I have now made some images from my copied CD's, and i had no problems with CloneCD and Alcohol 120%. Both programs can read the CD's perfectly when RMPS is enabled, no read errors on the CD (not sure, but should that not be expected, as both programs use their own drivers for CD access, so they could not get in conflict with RMPS-emulation? )

Over the weekend I will make a new install of Windows XP with hyper-threading disabled, then i will see if RMPS will work without it. Update probably on monday.

Development
13.06.2003, 11:43
Does switching off hyperthreading require reinstall? I am asking because i don't have such CPU. Does XP ask anything about hyperthreading during install?

AbatC
13.06.2003, 12:14
When you use hyper-threading Windows XP installs a multi-processor kernel (in device manager, you have 2 CPU running at 3.06GHz, also in task-manager two CPU are shown). When you disable hyper-threading (in Mainboard-BIOS);
INSERT INTO `portal_posts_text` VALUES
you have only a single-processor. As far as i know you cannot switch single/multi processor kernel without reinstall.

Windows XP doesnot ask a question when installing, it simply detects that there are (virtual) 2 processors...

Development
14.06.2003, 07:21
Got you. It is same as on Dual CPU systems. But if you disable hyperthreading in BIOS then XP still should run - multiprocessor kernel can work with one CPU too. At least it was so in NT/2000. You can test it.

AbatC
16.06.2003, 09:13
Another update:

As promised i tested RMPS with hyper-threading diasbled. IT WORKS!!!!! I tested it with several new installs (to be sure...)

When hyper-threading is enabled, RMPS freezes the system

When hyper-threading is disabled, RMPS works perfect...


Checked out what happens when you just disable hyper-threading without new install -> Win XP won't boot. So its not an option to just disable hyper-threading for running games with RMPS...

Copytrooper
16.06.2003, 09:17
Can you replace hyper-threading computer driver in device manager with non-hyper-threading driver (e.g. ACPI uni-processor driver);
INSERT INTO `portal_posts_text` VALUES
then shutdown, go into BIOS, disable hyper-threading, and boot XP again? Do you really need to do a complete re-installation of XP?

AbatC
16.06.2003, 09:49
Hm, will try that, but i am not sure about it...as far as i know there are some more things connected to the CPU than this driver...

AbatC
16.06.2003, 11:35
OK, first i have to apologize...When you disable hyper-threading in BIOS Windows XP will run. The crash at booting was related to another problem (nothing serious).

So, i did some testings with the device manager:

Hyper threading enabled, multi-cpu in device manager -> freeze
Hyper threading disabled, multi-cpu in device manager -> freeze
Hyper threading disabled, single cpu in device manager -> works
Hyper threading ENABLED, single cpu in device manager -> works!!

As you can see the problem only appears when you have the ACPI multi-prozessor active. You can switch from multi-processor to single processor with updating the device driver. Sadly, it seems that you cannot go back to multi-processor ACPI, as Windows XP doesnot show the required drivers...

Development
16.06.2003, 13:07
This problem is isolated and fixed, thanks for report!
I will make new beta soon and will send you for test.

AbatC
16.06.2003, 13:50
OK, just send it, I will test it...

Development
19.06.2003, 18:42
I have sent email to you - please reply to me with a valid return address.

AbatC
20.06.2003, 08:58
Do not know where is the problem - E-mail in profile is correct:


abatc@gmx.de

AbatC
20.06.2003, 10:27
Ahhhh, i hate GMX....


Use this mailadress:

ablase1s@smail.wis.fh-bonn-rhein-sieg.de