View Full Version : DaemonTools virtual drive gives Event ID 7 (bad block)

17.06.2003, 03:53

When mounting images either from a local HD or over a network share I keep getting booted out of the Installshield Installer with CRC errors due to the device, \Device\CdRom1, has a bad block appearing in the Event viewer in Windows XP. I have tried mounting several other images and always get the same problem, even though they install fine from other pcs.

Sometimes the installer makes it to 20% sometimes not, it seems to bomb out on the large files.

I have tried removing/re-installing my IDE drivers, aswell as daemontools itself with no success.

This is the output event viewer shows.

0000: 00680003 00b80001 00000000 c0040007
0010: 00000100 c000009c 00000000 00000000
0020: 09575000 00000000 00015faf 00000000
0030: ffffffff 00000001 c4000040 00000002
0040: 120a20ff 40000248 00005800 0000000a
0050: 4789a000 8191b888 00000000 81899b38
0060: 81536000 00012adf 01000028 0000df2a
0070: 0000000c 00000000 000300f0 0aea2a01
0080: 00000000 00000011 00000000 00000000

I have a Gigabyte GA-7VAXP
HD1 MAXTOR 6 L060J3 IDE Disk Device
HD2 Seagate ST38410A IDE Disk Device
NIC 3Com EtherLink 10/100 PCI TX NIC (3C905B-TX)
DaemonTools Version 3.33 (have also tried Ver 3.26)
Never had any burning apps installed especially NOT Easy CD creator :)

17.06.2003, 06:32
OK. I really have no idea why this fix works, but here goes anyway.

First off, Im mounting my bin/cue from a network fbsd samba share and would always get errors installing once I mounted an image.(see above)

Update... I also would get errors by transferring the bin/cue to my HD, Im thinking because whatever this checksum offload thingy is below was also perhaps fixing the Safedisc "bad blocks" whilst transferring to my HD ????

I managed to get 2 fixes to work, ( I have a 3com 3C905B-TX NIC)

1. Changing my NIC connect speed down to 10mbps stopped the install errors. (although it obviously slowed my network speed which makes installing kinda painful)

2. Whilst changing my connect speed I noticed two other options that were enabled. They are "Rx Checksum Offload" and "Tx Checksum offload".
Being the typical fiddler I am I decided to set my network speed back to 100mbps Full Duplex and DISABLE both the above options. BINGO it worked. I have no idea what it does, but I dont seem to need it enabled and so maybe you won't either. :)

Hope this helps a few people.


22.07.2003, 20:54
Thanks for the help, but what about when installing from local drives? I still get CRC errors.