No announcement yet.

AstroBurn Lite

  • Filter
  • Time
  • Show
Clear All
new posts

  • AstroBurn Lite

    Hi everyone!

    I have just installed your program and I like its simple interface VERY much but I have one problem! As I only burn some files to disk my DVD-RW device disappears in both file Explorer and Device Manager. The only way to get it back is the reboot of my PC. I am sure that you know why I am having this thing. Please let me know how should I solve this problem? Thanks!

  • #2
    Hallo, and welcome to the forums.
    Which OS are you using ?

    Please download this tool:
    Run it, highlight your optical drive on the left, then highlight upper/lower filters on the right.
    Which filters are installed on your system ?

    Is there any error/warning/information in Windows Event Viewer (Windows logs->System) at the time at which the drive disappears ?
    Last edited by Terramex; 19.12.2013, 23:35.
    I'm not employed by Disc Soft and my views do not necessarily reflect the ones of the company.


    • #3
      Hi Terramex and many thanks for your kind greetings and for your quick response!

      First these are the Filter Driver Load Order program results:

      Filter Driver Load Order Professional software bus analyzers, USB, SCSI, iSCSI, SAS, ATA, ATAPI, Fibre Channel, and more!

      Upper Class Filter: GEARAspiWDM
      Device Object: Optiarc DVD RW AD-7173S SCSI CdRom Device
      Lower Filter Drivers: No Lower Filter Drivers specified for this device

      Driver Name: gearaspiwdm.sys
      File Location: c:\windows\system32\drivers
      File Description: CD DVD Filter
      File Version: []
      Product Name: CD DVD Filter
      Product Version: []
      Company Name: GEAR Software Inc.

      And this is the Events Manager error I have found:

      Это устройство удалено из системы. (This device is removed from the system)

      (device) Устройство: \Device\RaidPort0
      (model) Модель: Optiarc DVD RW AD-7173S
      (FW version) Версия микропрограмм: 1-03
      (S/N) Серийный номер:
      (Port) Порт: 1

      - <Event xmlns="">
      - <System>
      <Provider Name="nvstor32" />
      <EventID Qualifiers="49374">7</EventID>
      <TimeCreated SystemTime="2013-12-20T17:44:05.075700000Z" />
      <Security />
      - <EventData>
      <Data>Optiarc DVD RW AD-7173S</Data>
      <Data />
      <Binary>0000000005002800000000000700DEC00000000000 00000000000000000000000000000000000000</Binary>

      What is that nvstor32? Thanks again for your response! By the way I have found out that sometimes I only have to just run (without burning) the AstroBurn and it removes the drive.

      Forgot to mention! I have Windows 7 32-bit Ultimate.
      Last edited by Terramex; 20.12.2013, 23:47. Reason: merged


      • #4
        nvstor32 is part of your nvidia storage driver.
        If applicable in your driver version please check the problem with disabled Command Queuing:
        If that doesn't help & you're not up-to-date, try latest version 15.58: NVIDIA DRIVERS nForce Driver Version 15.58 WHQL
        Though i've read that the pre-15.xx Vista drivers are less problematic - some even prefer the generic Microsoft drivers instead.

        If that also doesn't solve the problem please try to manually delete upper/lower filter as described here (Resolution):
        The CD drive or the DVD drive does not work as expected on a computer that is running Windows Vista (also works on Windows 7).

        In case you're using iTunes and if you need it for ripping/burning you maybe have to reinstall the GEAR driver (or iTunes):
        Driver updates - GEAR Software

        Which motherboard do you have ?
        Have you tried other burning apps facing similar issues ?
        Last edited by Terramex; 21.12.2013, 00:07.
        I'm not employed by Disc Soft and my views do not necessarily reflect the ones of the company.


        • #5
          Thanks for your reply!

          1) I have checked for Command Queing and I have the ability to unchecked that box only for my HDD. The DVD-RW box is unchecked and I also can't change it. I suppose there is no need to try unchecking my HDD box, is there?

          2) As for the driver I have that latest version installed already and I did it long time ago.

          3) As for the filter delete. Should I still try that if you would say I may pass 1-2 steps above? If I'll delete it would that do problems really only with the burning programs? I have the iTunes but I NEVER use it for burning and reinstalling AstroBurn is not a problem then. But what I am afraid of its if some other (not burning programs) may become unworkable. For example Steam, or any other programs which may loose my DVD device (e.g. drive letter). Or if you are sure that it may affect only burning software then again its not a problem and I will gladly try that registry editing.

          I have the ASUS M2N-E motherboard and I was using Nero for about 4 years and never had such problem. Recently Nero stopped working and I have downloaded some sort of the Nero repack (wanted to check if I really want to obtain the newer version) which I didn't like and I had Uninstalled then. Perhaps it (previous Nero and/or repacked Nero) could leave something in my OS? Best wishes!


          • #6
            Yes, you can try it without the first two steps, and it will only "negatively" affect programs which require their own filter driver.
            The reg-key itself will be automatically rewritten at next reboot - with fixed load order.

            It's a standard procedure, and by the way the solution for most problems in our forums.
            ...but just in case you can create a system restore point before you proceed

            General info regarding filter drivers:
            CD/DVD or disk problems? how to fix problems caused by filters - TechSpot Forums

            And just in case you need to manually remove any remains of the GEAR driver: DRIVERS: Windows - Updating, removing, 64 bit versions, etc - GEAR Software Knowledgebase
            I'm not employed by Disc Soft and my views do not necessarily reflect the ones of the company.


            • #7
              OK I have deleted the reg-key and I burned (continued the session) the CD for about 5 times and all was fine. But as I only have erased the CD then my DVD-RW device disappeared again. By the way, the Upperfilter reg-key did not reappeared back in the registry after the reboot.


              • #8
                Originally Posted by dimonlev View Post
                By the way, the Upperfilter reg-key did not reappeared back in the registry after the reboot.
                Actually i mixed this up with another issue/reg-key, sorry
                Should be created next time you install a software with its own filter driver.

                How is your Serial-ATA Configuration ? Look here at 4-30:

                I should also try generic Microsoft storage drivers, if i were you.
                But before that i would cross-check with another burning app such as the popular ImgBurn.
                Also please attach/upload a zipped Autoruns arn file (no installation required).

                As the forum provides more of an additional/secondary user-to-user support please also contact
                the official support team with reference to this thread.
                Last edited by Terramex; 21.12.2013, 21:02.
                I'm not employed by Disc Soft and my views do not necessarily reflect the ones of the company.


                • #9
                  Many thanks for all your kind help! I have installed the standard Microsoft storage drivers for my SATA controllers and it seems that the problem have gone. I have burned the CD for about 10 times and I have erased it for 2 times and no DVD device disappear. The other thing appeared instead is that almost every time after the program has finished the burning, or after erasing the system handles (including mouse and keyboard) for about 20-30 seconds and then it unfreezes. Supposed it could be that command queuing but I have no checkboxes with that in my drivers to disable it. Anyway I burn the CDs not so often, so that is not a problem instead of rebooting after each burn. So once again many thanks friend!


                  • #10
                    Glad your issue is (kind of) solved.
                    Still, we're trying to get access to a nforce system doing some in-depth tests with Astroburn.

                    Happy Holidays,
                    I'm not employed by Disc Soft and my views do not necessarily reflect the ones of the company.


                    • #11
                      Thanks Terramex! I really appreciate your help! I wish you also Happy Holidays!