No announcement yet.

Unable to create account on / order daemon tools on

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to create account on / order daemon tools on


    I’m interested in purchasing Daemon Tools Pro Advanced and before I wanted to place an order I wanted to validate if my email adress works. However:
    a) Creating a new account on Register :: . Clicking the ‘register’ link doesn’t do anything.
    b) Making a purchase on Store :: Clicking the ‘Buy’ button doesn’t do anything.
    c) Creating a ticket on Support :: doesn’t do anything ( unresponding)
    d) Creating a ticket through Send Message :: is not working. Clicking “send message” does nothing.

    I tried this out using both Firefox 3.6.16 and Internet Explorer 9. I first used Firefox and thought it may have been my NoScript addon and allowed the full website to run scripts, but that is not the issue. Next, I thought it may have been my Sunbelt VIPRE blocking ‘malicious’ scripts, thus disabled the webfiltering option, but still to no avail.

    It's a good thing I could register myself at least on the forums... I have to be honest and admit that I’m currently a lot less willing in setting through my purchase, especially if new customers have problems with even getting in contact...


    -- Threeps

  • #2
    Checked in IE 9 and FF 4. All works good.
    Please check your browser settings, addons and security software. Perhaps, disabling your Sunbelt VIPRE is not enough. Try to uninstall it for a time.


    • #3
      Hm, seems indeed a local issue. Ran it on a different computer (Ubuntu 10.10 - Firefox 3.6.16 using same plugins and settings as my Windows machine) and it works there. So it must indeed be a third party tool preventing me from doing this.

      The only tool I am actively running is Sunbelt VIPRE Premium and there are no logs of anything that is being blocked. Even when all features are turned off.

      Odd to say the least... (-:


      • #4
        Well, validating the email on my home computer won't work, since "Firefox can't establish a connection to the server at".

        Anything you can recommend me to check? I've been through nearly everything (even allowing all scripts to run).


        • #5
          My apologies for the quick succession in replies, but here's an update:

          I purchased the Daemon Tools successfully through my other machine. However, downloading and activating Daemon tools on the machine it was intended for has now become problematic since the error "Connection to server failed" popped up.

          VIPRE was also completely removed to see if it really is the culprit and it is not. Even with VIPRE removed and my Windows Firewall turned OFF the installation package cannot make a connection to the webservice.

          IE 9 complains it can't make a connection to

          I'll create an official ticket on my other machine and hope they can help me further there (especially since with no protection on at all the software fails to connect to it's server).


          -- Threeps


          • #6
            Ensure you don't have any entries in your hosts file. I guess that other computer is in the same network, therefore no ISP/router or network issues.

            Checking routes on local computer can be also helpful (start -> run -> cmd -> route print), please post "Active routes" then.
            Make something idiot proof, but then they just make a better idiot
            Peace Through Power


            • #7
              It was indeed an issue in the hosts.txt and has been fixed now. Thanks for the support! (-:


              • #8
                Unable to download license number

                I used the trial daemon pro which worked well. I then paid for my license number through PayPal. It was then found that my payment went to Disk Soft. I was given an address that would put my license number in. Still nothing works. I have contacted Daemon several times. COULD SOMEONE PLEASE HELP ME GET MY LICENSE NUMBER?

                Bruce Nightingale