No announcement yet.

system hangs after installing sptd.sys

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    now this is interesting.
    i had some problems with sptd.sys as well.
    i installed 4.06 a few days ago (and used it) and didnt reboot since then. i rebooted today - and the system would hang.
    read around the forums and deactived the sptd.sys in safe mode - worked. thought i'd update the sptd - did - and safe mode would crash with a bsod before i could do anything . so i even had to use the repair console thing to deactive the sptd.
    i then kicked starforce off my pc.

    then i tried a lot of stuff - my pc booted correctly with sptd and daemon tools uninstalled. daemon tools setup did not correctly complete - until i followed the guide on this thread's first page ( only i didnt have to rename the scsiport, it was enough to deactivate it and activate it again.
    now dt works and so does rebooting. Oo


    • #32
      Wow, this is very interesting that I found this.

      My problem: left for the wkend with a computer on.
      Came back to a computer that is stuck on a black screen (apparently right after the windows boot logo and before the login prompt).

      After some digging, I found that the computer restarted due to automatic updates (forgot to disable the autorestarts). I have a LOT of crap plugged into the USB: all 4 USB ports on the mobo + 4 ports on 2 add-on cards + 6 ports on the usb hub are taken. Also, I just installed a new HP all-in-one printer along with about 6-7 massive games and MS Office 2007. The Autoupdate installed 5-6 critical fixes.

      As you can see debugging this thing sounded like hell. Going back to the Last Known Configuration booted Windows, but after a reboot the same black screen. I was dumbfounded.

      After disabling tons and tons of startup items using 'autoruns', a nice free proggy by SysInternals and unplugging the USB hub, I narrowed it down to the USB hub. Incidentally, it has the Logitech webcam that I recently got plugged in. The instability of booting (sometimes it boots, most times it doesn't) didn't help diagnose the situation.

      I will try to see if it is indeed the webcam that is causing the lockups by testing some more, but I'm fairly confident.

      Can someone who has a webcam and fixed the boot problem confirm the steps necessary to fix it? How about going back to DT 3.47? I don't really like an idea of a "fix" that requires you to unmount every time you reboot.

      Also, it would be great if the above poster with the guide could post the exact locations of the files he was modifying as well as explain the problems he mentions.

      Thank you again for this topic.


      • #33
        i still have problem on this!

        is it DT or logitech that solve this? and are the working on it?
        some one who know somthing?


        • #34
          We recently checked again Logitech drivers for WebCam.
          My advice - do not use this hardware and especially software!
          Logitech drivers do not pass even standard Driver Verifier tests
          (maybe their developers do not know what it is): whith standard driver verifier settings you immediately get BSOD in
          LVcKap.sys. QuickCam package bloats your system with lot of
          drivers having "questionable" quality - no wonder it conflicts with something. They also install different keyboard and other hooks. One of our test systems could not even work at all even in standard mode without DT and any virtual drive software (all windows slow as shit, applications crash etc). So making our software "compatible" with Logitech drivers is matter of luck and we cannot guarantee anything.

          If you want to check your system is ok then remove DT and SPTD then reboot and run Verifier.exe: select standard settings and all drivers in system. Then reboot again your system and cross your fingers: if some driver is faulty verifier will BSOD your system. In such case best is not to install DT at all and not bother our support - bomb manufacturers of crapware you installed so they fix it first...

          Note: running Verifier slows down system significantly and is not recommended for every day use. To disable verifier (if you eg. had crash because of some buggy driver) just boot in safe mode and reset verifier settings.


          • #35
            I can unfortunately (for Logitech) confirm the buggy drivers,
            several systems I administer show similar symptoms, regardless
            if DT (or other vdrive-software in general) is installed or not.

            A driver which does not pass this test should not even be released.

            It is strange to me how a company with such (imho) good
            reputation and hardware-quality can release such.... faulty
            drivers. At least the very lowest quality assurance should
            test for such collisions. While we do our very best to provide
            workarounds in our software, we can not do everytime other's
            work nor even guarantee a quick fix for this. As Venom already
            explained, only to bomb out the manufacturer with requests
            and a clear statement will provide other manufacturers to
            (mis)use customers systems as betaplatform without even
            notice them about such heavy instabilities.

            BTW: I can also not recommend to use such drivers together
            with external HDD!


            • #36
              Thank god I found this page! Was having MAJOR boot problems to the point I tried reinstalling windows about god knows how many times :P looking at this page though solved my issue as I just bought a quickcam 5000 not that long ago and low and behold that's been my problem all along.


              • #37
                Originally Posted by Pogopuschel View Post
                then i tried a lot of stuff - my pc booted correctly with sptd and daemon tools uninstalled. daemon tools setup did not correctly complete - until i followed the guide on this thread's first page ( only i didnt have to rename the scsiport, it was enough to deactivate it and activate it again.
                now dt works and so does rebooting. Oo

                The solution ( does not work. It only helps to deinstall and reinstall Daemon Tools+SPTD.

                After 3 boot ups, i got a black screen before the "Welcome screen" appears.

                I think, that YASU makes problems... I activate (and deacitvate) YASU. Then i made a restart of my PC and got a black screen....


                • #38
                  Many thanks to VeNoM386

                  I had problems with random freezees. My system freezed almost every time i runned defrag, 3dmark and some others programs did the trick randomly too. Mouse stopped moving and only way to keep on working was to press reset. Problem started after installing daemon tools. Problem was not daemon tools but the sptd.sys witch conflicted with some of my drivers. I followed venom386's tips and used verifier.exe. Yes i did got bsod after reboot. The REAL problem was driver called aegisP.sys (wonder what it is?). I even installed my OS again once earlier, but still had the problem. Now thanks to venom386 my comp is stable with daemon tools (great software btw. )


                  • #39
                    According to a Google search, aegisP.sys is a IEEE 802.1X Protocol Driver by Meetinghouse Data Communications.


                    • #40
                      i need some urgent help! please

                      ok. here's the deal. recently i uninstalled daemon tools not knowing what awaited. i didnt have anymore use for it so i got rid of the program. upon trying to rebot my computer, i had the problem metioned so many times by the people on this thread. my computer would get to the boot screen and then hang. after attempting to restart it in safe mode with no success, i had a friend of mine remove my SATA hard drive and put it into his computer. we removed the sptd.sys file but after that didnt work we replaced it. when trying to boot in safe mode and escaping out of the sptd.sys load, i got the blue screen and an automatic restart. we couldnt access my registry through his computer and therefore couldnt delete any of the files. i was wondering how each of you got the chance to delete these files and boot up your computer. i joined this forum just because of this specific problem. please help!


                      • #41
                        Well i was having the same problem with DT and the sptd.sys system hang at boot. Since i had a Norton ghost backup that didn't have deamon tools on it since i recently reinstalled, i restored my backup image. Then when i was ready to install DT i went to to download the latest sptd version and rebooted my computer.

                        Everything booted up fine. So i went to install daemon tools and made sure it does not start up with windows. Now everything works fine.


                        • #42
                          I just downloaded the latest version of DT which includes SPTD1.43. I had DT version 3.46 installed. When I downloaded the latest version and started the installer, it asked me if I wanted to upgrade DT. I did have an image mounted before I did the upgrade. After I rebooted the computer to finish installing DT, the computer hangs right after I log in. I am able to boot the computer fine into safe mode and last known good configuration. Any ideas on what I can try to fix my problem? I'm running XP.


                          • #43
                            Uninstall and remove all traces of 3.46, then download the standalone SPTD 1.5 and install it. Then install 4.09.1 again.


                            • #44
                              So are these type of problems related to systems with SATA drives?


                              • #45
                                Originally Posted by Christoph_vW View Post
                                I figured out why my system always hangs when trying to load sptd.sys.
                                my config:
                                nVidia nForce 4 Chipset (driver ver. 6.69)
                                S-ATA II Harddisk
                                daemon-tools 4.03 x64
                                The problem is Native Command Queuing - after disabling it daemon-tools works just fine.
                                I am sorry, but I just don't know how to disbale [Native Command Queuing].
                                I have WinFast PX8400 GS TDH(NVIDIA) (512MB).