Announcement

Collapse
No announcement yet.

WaitForApp Headache

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • yesterday_87
    replied
    User error found

    I found what was wrong-it was user error
    Second question:Is it ok for timeout to be 10?
    Thanks in advance!
    I was thinking that WaitForApp would wait 10 seconds then wait for app to terminate when in fact it was only waiting for 10 seconds. Once I set it to 0 everything work like it should have.
    anyway thanks for all ya help.
    Last edited by LocutusofBorg; 30.11.2007, 21:32.

    Leave a comment:


  • AndreP
    replied
    Originally Posted by yesterday_87 View Post
    First question I have is: in WaitForApp, do you wait the full path for the application? or just the name of it?
    No, the exe name.

    Example:
    Is RunApp-->C/Programs/Sport/Game.exe

    then

    WaitForApp-->Game.exe


    Originally Posted by yesterday_87 View Post
    Second question:Is it ok for timeout to be 10?
    Yes, its enough.

    Can you Speak German?

    I have a Guide, for Daemon Script
    http://rapidshare.com/files/55777503..._Anleitung.pdf

    Leave a comment:


  • Tiger-Heli
    replied
    Don't know if this helps, but I use a similar script with Batchrun and don't have any problems. More info in the suggestions thread, but basically, I have a DaemonScript
    LoadApp.DaemonScript, which is just:
    DeviceCount 1
    Mount <image>
    and a DaemonScript Bye.DaemonScript (Same for all games) with:
    Unmount
    DeviceCount 0

    Then a batch file with
    App - DaemonScript.exe Parameters LoadApp.DaemonScript Wait for exit

    App - App Wait for exit

    App - DaemonScript.exe Parameters Bye.DaemonScript

    Hope this helps!!!

    Leave a comment:


  • yesterday_87
    started a topic WaitForApp Headache

    WaitForApp Headache

    I am having problems with keep an image mounted and I think with WaitForApp.

    This is how I have the script set up

    Mount

    RunApp

    WaitForApp--Time out 10 sec and Wait for application to be terminate

    Unmount

    Due to how the game runs I can not alt-tab or any the from the game main, I have to wait until I start a game. by that time the disk is unmounted and the game quit because the is no game disk mounted.

    If I change it to Wait for application to be executed with the 10 second wait I can get the game started but I restart the game from the main menu the game quits.


    First question I have is: in WaitForApp, do you wait the full path for the application? or just the name of it?

    Second question:Is it ok for timeout to be 10?


    Any other solutions would be welcomed.

    Thanks in advance!
Working...
X