Page 4 of 4 FirstFirst ... 234
Showing results 31 to 39 of 39

Thread: awxDTools keeps saying something about a .dll

  1. #31

    Default neat

    That's a really neat hack Jito
    the modern world:
    net helpmsg 4006

  2. #32
    Jito463's Avatar
    Join Date


    I also discovered if I hex-edit the awxDTools.dll file, I can modify the context menu to read Alcohol-Soft instead of Daemon-Tools (just looks better when I'm using Alcohol instead of DT).

  3. #33
    New User
    Join Date


    I have the same problem (failed to register). I'm using Win2k (futils is a part of XP but not for Win2k).

    please give me a solution

  4. #34

    Default Re: awxDTools keeps saying something about a .dll

    Quote Originally Posted by Petzi
    I have the same problem (failed to register). I'm using Win2k (futils is a part of XP but not for Win2k).

    please give me a solution
    Please upload a screenshot like theo. t. posted. You probably have short filenames already turned on.

    Look for the mention of "NtfsDisable8dot3NameCreation" on this webpage:
    the modern world:
    net helpmsg 4006

  5. #35


    I'm still getting failed to register extensionon win2k3 x64

    I installed both Visual C++ 2005 Runtime Libraries x86 and Visual C++ 2005 Runtime Libraries x64

    then I ran fsutil behavior set disable8dot3 0
    then I installed daemon tools in c:\daemon, turned off secure mode and installed awxdtool in c:\daemon

    I got the error again , I tried twice to be sure

    on win2k3 32bit it works just fine, what's the problem ?

  6. #36
    New User
    Join Date


    Quote Originally Posted by alii
    I am running Windows XP 64 bit edition and I was having the same problem with awxDTools not registering. I tried formatting and reinstalling windows but I kept getting the same error. I also tried the other solutions in this thread but they did not work for me. Below is what resolved the daemon.dll issue for me.

    Download and install "Microsoft Visual C++ 2005 Redistributable" yes the 32 bit version not the 64 bit version (Google it. It should be the first hit). The name of the file is vcredist_x86.exe

    It seems that the installer lays down only the 64 bit version of C++ files but the x86 or 32 bit version is needed too.

    How I figured it out:
    I double checked the event viewer Start \ Settings \ Control Panel \ Administrative Tools \ Event Viewer \ System Logs and I saw 3 error messages. One of the error messages was

    "Dependent Assembly Microsoft.VC80.MFC could not be found and Last Error was The referenced assembly is not installed on your system."
    (Note: if you see DCOM errors in the log, this fix alone may not resolve the issue)

    I researched the error and it referenced files that should have been installed by the "Microsoft Visual C++ 2005 Redistributable (x64)" but these files did not work. I then used the 32 bit version "Microsoft Visual C++ 2005 Redistributable" and it worked. I then uninstalled everything, rebooted and installed Daemon Tools then awxDTools. I received the daemon.dll error. I then installed "Microsoft Visual C++ 2005 Redistributable" and "Re-Register Extension". It registered fine. Now I can right click on images and mount them.

    I hope this helps.

    This worked beautifully. Thank you!

  7. #37


    Quote Originally Posted by Petzi
    I have the same problem (failed to register). I'm using Win2k (futils is a part of XP but not for Win2k).

    please give me a solution
    ok, took me quite long to switch from 3.47 to 4.0.3 because of problems installing sptd and awxDTools (w2ksp4). Now I tried again and got the daemon 4.0.3 running but awxDTools still fails to register the dll. Seems only a few people still use w2k - so not much help here.

    What I did and what seems to go wrong:

    - tried to install awxDTools -> result is the error when trying to register the dll
    - copied all registry settings from a wxpsp1 and put them in my w2k registry with the failed install -> awxDTools appears and seems to work ... at least a little bit
    - most of the images (iso, cue, mds - all the same behavior) do not mount with 'unable to open file in kernel mode' error message, but if you put any image to the root directory of any drive it works! (or change all subdirectories to uppercase)

    Ok, I found something about wxp and ObCaseInsensitive (interesting for all but win32 like posix) to turn case sensitivity of, what seems to be default on wxp and impossible on w2k. Also somebody mentioned Alcohol 120% accessing images with uppercase file and path (visible in history) and making problems this way.

    If you try to mount an image using command line you'll notice that the path is case sensitive. Drive letter and filename are not. Does awxDTools pay attention to this? If not, is it possible to fix it? Or is it possible to make posix case insensitive in w2k?

    Maybe this points even to the install problem in w2k although a test with uppercase names failed

    arniWORX, could you please take a look at the problem?

    edit by Admin: Please don't post your message more than once. The forums are moderated, which is why your posts don't show up immediately.

  8. #38

    Default Here is how i did it.

    Uninstall awxdtools
    uninstall daemon tools
    make sure 8.3 filename creation is on by following steps below:
    1. click start
    2. click run
    3. paste "fsutil behavior set disable8dot3 0"
    4. click enter
    5. reboot.
    install latest daemontools, i have 4.06
    right click the tray icon, select options, make sure "secure mode" is not checked
    next go here
    install unlocker
    go to daemontools directory
    right click deamon.dll
    select unlocker, select unlock all
    install awxdtools
    turn back on secure mode on deamon tools

  9. #39


    well Joules i tried that i'm running Vista 64bit with all the latest version of everything and i tried your fix and unlocker dosen't even open when i try to open the dll with unlocker what am i supposed to do

Page 4 of 4 FirstFirst ... 234


Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts