So yeah, I upgraded to Vista RC1(still RC1) but it didn't tell me to uninstall DT untill i got Vista working. Anyway, now I can uninstall DT 3.47 (and vista blocks it due to "compatibility issues"), if I try to uninstall it gives me an error saying "setup is unable to validate instalation". I also took a look in the registry, and couldn't find the keys(after looking through where it told me too I just did a search for "daemon" and it still didn't find anything)

I also tried reinstalling 3.47, so I can uninstall it properly but vista blocks the installation too. Then I decided i'll just go ahead and try to install 4.0x over the old one, assuming there is some kind of upgrading system, but whenever it asks me about the kernel debugger and instqalling sptd it doesn;t matter if I press Ok or Cancel it just quits, so I downloaded the seperate driver installing file. I went to the command promt, and just typing "sptdinst_x86.exe add" didn't work, os I typed in the whole adress and it looked like it was doing something, but it brought up the same screen and gave me the same problem(I pressed Ok and the command promt just created a new line) so I tried removing the SPTD drivers and it said that thye were never installed.

So that is pretty much everything I can think of, if you need more information let me know.

Also, I tried runing all of these normally, as administrator(which my account is anyway, but I thought it might help) and with compatibility mode set to XP SP2. I really don't know what to do since I am pretty sure that screen would come up during installation even if the SPTD drivers are alredy installed, so it qould quit in the middle either way.

Thanks a lot anyone who tries to help, I use Daemon Tools a lot, and I like it better than other mounting programs(although it might not matter if the problem is wih the SPTD drivers after all) so it would be great if I could get this to work.

Sorry if this a double post, but I can't see the old one I tried posting and I really need help