I am currently having an issue with running YASU with Daemon tools. When I click on YASU, I get the error message: "could not find any device(s) to hide... click OK
to exit Y.A.S.U."

I am running Vista RC2 32bit on a Compaq R3140US laptop (Athlon64 3000, 1gig ram, WD160g hd, DVD burner). Currently using Daemon V4.08HE and YASU v1.0. I was running this
same system with an earlier version of Daemon tools, and everything worked great until I had an issue with a bootup error on my PC that caused a blue screen and reboot. I repaired my computer with the Vista DVD repair option (it appeared to be corrupted data in the C: drive formatting) and now everything is working except YASU. I can use Daemon tools and mount or dismount a drive, run the mounted drive, etc. but get the above message anytime I use YASU.
I have tried uninstalling both YASU and Daemon tools, editing the registration to delete any leftover registry files, downloaded and installing the latest versions of both
with no success. Even tried adding two or three additional virtual drives. BTW, the latest version of YASU v1.06 I tried, did not do anything but max out my CPU. It does that until you use task manager to shut it down. I would prefer not to format the C: drive and reinstall everything. Any suggestions would be greatly appreciated!