Page 1 of 2 12 LastLast
Showing results 1 to 10 of 12

Thread: unable to mount from command line

  1. #1
    New User
    Join Date
    23.10.2006
    Posts
    21

    Default unable to mount from command line

    I have the latest version of DT and SPTD installed and running. Everything works fine except for mounting an image from the command line. From the help file it shows it should be something like this...

    daemon.exe -mount0."C:\imagename.iso"

    But it keeps on giving me an "unknown switch in command line" error. What am I doing wrong?

  2. #2

    Default

    Try to replace the dot (".") with a comma (","). And ensure there is a space after mount and the device number.
    daemon.exe -mount 0,"C:\imagename.iso"
    Everybody be cool! You, be cool!
    They'll keep fighting! And they'll win!

  3. #3
    New User
    Join Date
    23.10.2006
    Posts
    21

    Default

    Ah, thank you very much! The online help files should be updated to reflect this.

  4. #4

    Default

    The online help is perfect regarding this:
    Example: daemon.exe -mount 0,"c:\My Images\nameofimage.cue".
    Everybody be cool! You, be cool!
    They'll keep fighting! And they'll win!

  5. #5

    Default

    Quick question which is sort of related so I thought I'd reply here instead of creating a new thread...

    I've successfully mounted an image from a command line but I get a dialogue box saying "Secure mode confirmation for command line: -mount 0, C:\Test\Test.cue"; Yes or No...

    Is there a way to turn this off? I would really like no user interaction if possible when mounting an image.

    I tried adding -securom on before or after the -mount but that just gives another dialogue box; Yes or No.

    Your help is much appreciated

  6. #6
    GERMAN TRANSLATOR
    Blazkowicz's Avatar
    Join Date
    09.11.2005
    Posts
    6,401

    Default

    If you are using DT Lite you can disable secure mode through the options.
    Make something idiot proof, but then they just make a better idiot
    Peace Through Power

  7. #7

    Default

    SecuRom is NOT what you are looking for to acomplish this. What you need to do is right click on the DT sys tray icon, go to Options, and turn off the "Secure mode" option, This will stop the nagging command line mount popups.

    Brasco

  8. #8
    New User
    Join Date
    29.07.2008
    Posts
    4

    Default daemon command line in network fail

    Hi,

    I developed a script that mount a image file *.iso in remote computer with help of psexec of pstools.

    Simple run a script with the next command:

    psexec \\computer -c -d -s -i daemon.bat

    daemon.bat containts next line:

    CD "D:\Archivos de Programa\DAEMON Tools\"
    daemon.exe -mount 0, M:\ILEX\disco-azul.iso

    The M: is a network mapped folder from another computer (server).

    If i mount to hand in the icon try and use M:\ILEX\disco-azul.iso work fine, but from command line dont work, display next error:

    Unable to mount image. Invalid image file

    S.O of server: Windows XP SP2 Professional
    S.O. of client: Windows XP SP2 Professional

    I hope to can help me with this problem

  9. #9

    Default

    @uNk : Remove the space after the comma
    the modern world:
    net helpmsg 4006

  10. #10
    New User
    Join Date
    29.07.2008
    Posts
    4

    Default

    I check to remove the (",") comma from line, but dont work either.

    I put an image of error and you can see the line command send.



    Details of daemon version:

    - Daemon version: 4.09E
    - SPTD version: 1.50
    - Secure mode: OFF
    - Automount: ON
    - InUsecheck: OFF
    - AutoStart: ON
    - Tray icon: ON
    - Check for updates: ON




    Thanks and best Regards

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •