Showing results 1 to 8 of 8

Thread: DT Pro Agent Tray Menu: not able to use with mouse

  1. #1
    New User
    Join Date
    01.07.2007
    Posts
    2

    Default DT Pro Agent Tray Menu: not able to use with mouse

    When you open the DT Pro Agent Tray Menu (rightclick) [B], and there is not enough space on the right, the submenus [A] appear on left.

    If you want to select anything in the submenu now, it is impossible to do this with the mouse, because as soon as you move the cursor over that "DAEMON Tools Pro"-bar, the submenu disappears.
    Even though i am a friend of keyboard usage, i think the usability suffers a lot. For this reason, most people will simply use the normal GUI, and the Agent becomes needless...

  2. #2

    Cool DTPro Tray

    Quote Originally Posted by 0xygen View Post
    When you open the DT Pro Agent Tray Menu (rightclick) [B], and there is not enough space on the right, the submenus [A] appear on left.

    If you want to select anything in the submenu now, it is impossible to do this with the mouse, because as soon as you move the cursor over that "DAEMON Tools Pro"-bar, the submenu disappears.
    Even though i am a friend of keyboard usage, i think the usability suffers a lot. For this reason, most people will simply use the normal GUI, and the Agent becomes needless...
    ========
    Absolutely rt u r and it's very irritating and time killing also.

  3. #3
    Experienced User

    Join Date
    27.09.2005
    Posts
    822

    Default

    been mentioned before in another thread...
    you can do the following work around...
    right click to bring up the menu, then use the cursor keys to navigate it.. i think the issue is from the 'banner' bitmap used, as somehow it breaks the menu region...

  4. #4
    Experienced User
    Reef's Avatar
    Join Date
    30.03.2003
    Posts
    860

    Default

    This is probably cause by some Windows tweak to make menu's work faster.

    You could check this registry value:
    HKEY_CURRENT_USER\Control Panel\Desktop\MenuShowDelay

    Windows default setting for this key is 400. If it is set to 0 or a very low setting, menu's will appear faster, but the drawback is that they also will disappear faster (e.g. when moving your mouse over the image in the DT Pro tray menu).

    After changing this registry value you either need to logoff and logon again, or reboot for changes to take effect.

    PS: Only edit your registry if you know what you're doing.

  5. #5
    Experienced User

    Join Date
    27.09.2005
    Posts
    822

    Default

    mentioned before reef, other menus do not have the same problem, icq is owner drawn, doesnt happen in it, my own tools which use ownerdrawn also do not do this... the menushow delay should have no effect on this, its clearly a bug in the WM_DRAWITEM message, either that or the 'banner' is moved onto the menu and throws the tracking off, thus killing the sub menu...

    even windows own start bar doesnt suffer from this, and its definately ownerdrawn...

  6. #6

    Default

    This is weird, i had same bug and it was because windows show delay, i've corrected from 20ms to 100 and now it works great.

  7. #7
    New User
    Join Date
    01.07.2007
    Posts
    2

    Pfeil

    Maybe my definition of "works great" is a bit different from yours, because imho if there is an error over a short period, you can't fix that error by just making the error recognition slower.

    It should not depend on how fast you move your mouse or how fast the menu disappears, if the menu works or not. Either you are able to fix it, or you just remove it.
    The MenuShowDelay is not intended for making gaps between submenus.

    I have removed the annoyning banner by myself, and now it's possible to have fast menus and to reach a submenu without moving your mouse at 20mph. In fact I replaced it with a 1x1 pixel graphic to avoid messages about missing resources. Now about 0.1 mph "mouse-speed" is enough.

    That solution is fine for me, but it would be better if it will be fixed/removed for everyone with the next updates.

    Thank you for your responses!

  8. #8

    Rotes Gesicht

    Quote Originally Posted by 0xygen View Post
    Maybe my definition of "works great" is a bit different from yours, because imho if there is an error over a short period, you can't fix that error by just making the error recognition slower.
    It should not depend on how fast you move your mouse or how fast the menu disappears, if the menu works or not. Either you are able to fix it, or you just remove it.
    The MenuShowDelay is not intended for making gaps between submenus.
    I have removed the annoyning banner by myself, and now it's possible to have fast menus and to reach a submenu without moving your mouse at 20mph. In fact I replaced it with a 1x1 pixel graphic to avoid messages about missing resources. Now about 0.1 mph "mouse-speed" is enough.
    That solution is fine for me, but it would be better if it will be fixed/removed for everyone with the next updates.
    Thank you for your responses!

    Changinging menu delay is not a technical solution. Why should I change it!! It was not happening with earlier versions. I finger my windows out of my need because I purchased DTPro ?

Bookmarks

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •