Showing results 1 to 7 of 7

Thread: Image is locked after unmounting (not Securom related)

  1. #1
    New User
    Join Date
    24.12.2003
    Posts
    4

    Default Image is locked after unmounting (not Securom related)

    Operating System: Win98SE/Win2K SP4
    Burning Software: Nero 5.5.10.35, CloneCD 3.3.4.1
    Anti-virus Software: none
    DAEMON Tools Version: 3.43

    I've installed the new 3.43 on Windows 98SE and Win2k SP4. When I mount an image and unmount it later, the image file isn't closed by Daemon-Tools.
    This means that in order to delete the image file or open it with other programs, I have to close the DaemonTools tray application and open it again on Win98SE and I have to reboot my computer in Win2k SP4.
    While this might not be as important as other fixes, it is still a pain if you want to burn an image and the burning software tells you that it can't open the image since it is locked.

  2. #2

    Default

    I don't have this problem. You should download handle from www.sysinternals.com and try to find out what is keeping the file open.

  3. #3
    New User
    Join Date
    24.12.2003
    Posts
    4

    Default

    I didn't use "Handle" for my research, but "Handle" tells me the same: DAEMON.EXE has opened the imagefile.
    And the program I use additionally tells me it's opened in "RO, DENYALL" Mode. You can guess what that means yourself. This also explains why no burning program can use the file or why you can't delete it. In Win2k "Handle" tells me that an unknown process has opened the image after I closed the tray application. (very helpful)

  4. #4
    Administrator



    Join Date
    06.11.2002
    Posts
    2,044

    Default

    Daemon never opens image in DENY ALL mode. It always uses only READ ONLY with allowed access to other processes. Otherwise other prograns could not see it, but Alcohol eg. can mount same image too.
    When image is opened then daemon.exe closes all handles (only kernel has control over it).
    What are these images (what protection)?

  5. #5
    New User
    Join Date
    24.12.2003
    Posts
    4

    Default

    The images have no protection. They are normal ISO/2048 or ISO/2352 images, some made from comercial CDs (Microsoft and Adobe mainly) and some burned on my own with many smaller programs on it. Just plain *.ISO files, no missing or invalid CUE/MDS/BWS/... files.

    I didn't have these problems before, they started with version 3.43. And I can't open the files with any other program while they are mounted or after they have been unmounted (like hex-editors, burning programs, ...).

    I believe you that DaemonTools normally uses RO/shared file mode, since with previous versions you could even edit images while they where mounted, but something doesn't work correctly in this version. I don't believe that it is a driver problem on my computer, since it happened on two computers at the same time and when downgrading to 3.41 all the problems disappeared. Only 3.43 seems to be affected.

    I can't say anything about Alcohol since I'm a BlindWrite user and Alcohol is basically just DaemonTools with more virtual drives and burning support, so it would probably behave in the same way.

  6. #6
    Administrator



    Join Date
    06.11.2002
    Posts
    2,044

    Default

    I just mounted ISO in 98SE then viewed it with hex editor, renaming it causes error of course. Then i unmouned it and cound rename it. So it is ok.
    I don't understand too what happens on your PC. I strongly recommend you check your system - it is either prob with some antivirus or trojan!
    Or maybe other software.
    I repeat - Daemon NEVER opens ISO in DENY ALL mode! It allows read.

  7. #7
    New User
    Join Date
    24.12.2003
    Posts
    4

    Default

    Now I tested it one more computers and OS and result is: (all results after unmounting! German OS versions)
    on VMware Win98 causes blue screen
    on VMware Win98SE causes blue screen
    on VMware Win2k SP0 image isn't locked
    on VMware Win2k SP4 image is locked in exclusive mode
    on VMware WinXP SP0 image is locked in shared mode
    on my Win2k SP4 image is locked in exclusive mode
    on my Win98SE image is locked in exclusive mode
    on Win2k SP3 (from a friend) images is locked in shared mode
    on two WinXP SP1a (from friends) image is locked in exclusive mode
    on other WinXP SP1a (from friend) image isn't locked

    So totally:
    n/a: 2
    not locked: 2
    locked, but shared: 2
    locked, but exclusive: 4

    So no real result, but more "not working OK" than "working OK". And this topic also http://www.daemon-tools.cc/portal/viewtopic.php?t=2069 shows that not only I and my friends have the problem.

Bookmarks

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •