Showing results 1 to 6 of 6

Thread: Call of Duty 4: Strange behavior

  1. #1
    Experienced User
    Reef's Avatar
    Join Date
    30.03.2003
    Posts
    860

    Default Call of Duty 4: Strange behavior

    On my gaming PC I am running the regular DT 4.10. This PC does not have any optical IDE drives, images are mounted over the network.
    This PC also has YASU automatically startup and cloak when Windows starts. But with CoD4, the game keeps asking for the original DVD. Tried uncloaking and quitting YASU, but didn't help.
    Then I removed YASU from startup and rebooted, and then the game started without any problems. Ran YASU again, but didn't cloak yet, game would still run. But after cloaking it asked for the DVD again, even if I uncloak and quit YASU.

    So if YASU has been used to cloak drives, just uncloaking doesn't seem to be enough to get this game running. It will only run again after a reboot.

    BTW: Game also runs fine on vIDE when there are optical IDE drives attached.

  2. #2
    Experienced User

    Join Date
    27.09.2005
    Posts
    822

    Default

    maybe its yasu detection?

  3. #3
    Experienced User
    Reef's Avatar
    Join Date
    30.03.2003
    Posts
    860

    Default

    It seems YASU doesn't put everything back in its original state after uncloaking, it only gets reset after a reboot.

    In short:

    PC boots: game runs
    Start YASU but don't cloak drives: game runs
    Cloak drives: game no longer runs
    Uncloak drives: game still doesn't run
    Quit YASU: still no go
    Reboot: game runs again

    This even happens with the original DVD in the drive and no image mounted.

    If YASU has been used to cloak drives, then the only way to play CoD4 is to reboot the machine.

  4. #4

    Default

    Your lucky, i cant get COD4 to play at all off the image, i re-installed everything. burned like 3 diff images and no go. Was there anything special you had to do to get it to run?

  5. #5
    Experienced User
    Reef's Avatar
    Join Date
    30.03.2003
    Posts
    860

    Default

    I never burn my images to disc, I just mount them. But if you have optical IDE drives attached, the game will only run in a vIDE drive. Therefore you'll need DT Pro Advanced.
    Another solution is to disable your real optical drives in device manager, then the game will run using the regular DT 4.10.
    Last edited by Reef : 25.11.2007 at 12:04

  6. #6

    Default

    dude not to be gay or anything, but i kinda love you. like ALOT.

Bookmarks

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •