Showing results 1 to 4 of 4

Thread: Win 7 can't install DT

  1. #1

    Default Win 7 can't install DT

    okies got a problem thats doing my head and i can't seem to find a thread that has helped.

    i had vista on a brand new laptop, had DT on it prior and then upgraded to win7 without uninstalling DT.

    i then reinstall DT afterwards to only get what looks like a common problem, a looping installation that always asks to reboot.

    You must reboot after previous operation

    Open Registry Editor (run regedit command) and check if one the following key exists:

    * HKEY_LOCAL_MACHINE\Software\19659239224e364682fa4b af72c53ea4 (DT Lite)
    * HKEY_LOCAL_MACHINE\Software\14919ea49a8f3b4aa3cf10 58d9a64cec (DT Pro)

    This is volatile key of DAEMON Tools installation which should disappear after reboot. If it still exists, delete it, and try again.

    If you have problems with SPTD layer installation, download SPTD stand-alone installer from - Published Software Download

    * x86 version is for 32bit OS (Windows 2000, XP and above)
    * x64 version is for 64bit OS (Windows XP x64, Vista 64bit, etc.)

    Run the SPTD installer and update to latest version. After reboot run installer again, and check the message. If it says SPTD version (currently v1.62) detected, SPTD installed correctly. You can continue with DAEMON Tools installation then.

    If it says no SPTD layer version detected, or gives an error message, DO NOT install DAEMON Tools! Search the forum first for a thread covering your problem, before starting a new one!

    Also check if r0 key exists in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\sptd.

    Delete r0, reboot, then try again.

    As last resort uninstall all software using SPTD layer (e.g. DAEMON Tools, Alcohol), open Registry Editor, browse the

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\sptd key, set Start value to 4 (i.e. disabled), and reboot.

    After reboot delete complete sptd key in services hive - you must enable all permissions on sptd/cfg key first.

    Then reboot, and reinstall, beginning with SPTD layer. After reboot check correct SPTD layer installation (see above) before reinstallation of DAEMON Tools!

    did all that except the last part, as there isnt a HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\sptd key, listed.

    The standalone installer of sptd says i have no sptd installed, so i click install, it does it's thing and asks to reboot!!!!!!

    *pulling hair out*

    it does the same thing as DT always asking to reboot but never installing!

    is there anyone who can help as i've had this problem since win7 first came out, and i really need to use it now

  2. #2
    Blazkowicz's Avatar
    Join Date


    Which security software are you running?
    Make something idiot proof, but then they just make a better idiot
    Peace Through Power

  3. #3


    im running AVG 9 and whatever comes with win 7.

    i had avg before with DT no problems, only ever these problems since upgrading from to win 7.

    i tried installing the sptd again and after 8 restarts i was getting annoyed. just won't install, always asking for reboot.

  4. #4
    Blazkowicz's Avatar
    Join Date


    You may try first to deactivate/uninstall every security software.
    • Spyware Doctor is known to interfere with SPTD's work
    • ZoneAlarm Extreme (latest) not (at least not when i tested yesterday latest one on Win 7),
    • also had no problems with NOD32/Eset Smart Security
    • and works fine with Kaspersky Internet Security.

    In case it still doesn't get installed, please send a message with all information and a link to this thread, thank you.
    Last edited by Blazkowicz : 11.12.2009 at 00:52
    Make something idiot proof, but then they just make a better idiot
    Peace Through Power


Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts