I'm not sure if I'm following every rule with this post, but I'm really desperate. And I'm really frustrated, I hope someone can help.

All right, explain this to me.
I've done this before, I mounted my ME2 disc 1 to the SCSI Virtual Drive that Daemon Tools automatically detected. And the game setup launched itself. But both .iso (disc 1 and 2) files were on my desktop.
Now they are separately on different discs.

That was on a different computer.

Now when I try it on my computer, nothing happens. I insert disc 1, mount it to Virtual Driver that Daemon detected K: and nothing happens. I go to explorer and see "DVD Drive (K:)" when it's supposed to say "MassEffect2 (K:)"
Sure when I press the "mount" button, it says "Mounting image". And when I do so, the DVD Drives name changes to MassEffect2 for about 5 seconds after it changes back.
I tried copying both image files to my computer but it didn't let me, after halfway through a error message pops up and the transfer cancels.
I also tried mounting directly from the disc (not sure if that's the right metaphor) with MagicISO but it didn't let me.

I only have one CD drive (E:) and I don't know what the (K:) is there for.
As you can probably tell, I'm no expert at this shit. So please, how do I make this work?