my 500GB USB hard disk worked well all the time, until I installed the latest version of Deamon Tools Lite on my Windows 2003 x86 server.

Please help me and tell me what I should try to get it back like it was before (I don't need a virtual CD drive).

I try to give as much info as possible, please ask for more:

The automatically created new virtual CD drive got its drive letter E:, and showed instead of the USB disk. So I changed the drive letter for the virtual CD drive to V:, but it didn't help: my drive E: didn't reappear, even not after a second reboot (first was for SPTD installation).

So I tried to unplug/plug the USB disk in combination with reboots and many tries to assign a drive letter in windows disk management. There I always got an internal error and the hint to look into the system log, but there was nothing interesting.

So I uninstalled DTL including reboot, no change.
So I uninstalled SPTD including reboot and check that all files are really gone, no change.
I also installed the latest version of SPTD manually and uninstalled it again, no change.

I tried the USB disk in a different computer, there it worked like always.

I tried a different USB stick in this computer, and it worked. So it's not a general failure of USB disks - just for this drive.

I got access to the disk by mounting it with Paragon Partition manger. Interestingly, there the mounting worked and the drive showed as E: in the file explorer. File operations of any type work, but windows partition manager doesn't show the driver letter assignment and still shows internal errors on any operation including viewing the properties. It even assigns this same drive letter E: to my other USB drive when I plug it in.

The drive letter E:, mounted by Paragon, stays when I unplug the USB disk (unlike how it was before).
After a reboot the disk is gone again, windows can't mount it, and I can use Paragon again if I need access.

The windows partition manager (gui and diskpart tool, too) don't show the volume in the volume list. So, in diskpart I cannot select it, and therefore not try to mount it.
In the GUI tool, it is also not shown in the (normally hidden) volume list, but it is shown in the graphical display, without a drive letter. But I cannot use any options there, I always get "the operation didn't complete" or "internal error" (translated from german!).

After lots of tries and lot of reboots, I have no idea.
Any hints?