Showing results 1 to 5 of 5

Thread: MCI CD audio fails after uninstallation

  1. #1

    Default MCI CD audio fails after uninstallation

    Hi!

    When I uninstall Daemon Tools 3.26 from my system or set it to zero emulated drives all applications (Windows CD player, Quake2, ...) that try to use MCI to play CD audio tracks from the two real drives just fail with some error messages. When I re-enable a single drive in Daemon tools all apps work again, although most games seem to try to play CD audio from the emulated drive (which is why I wanted to disable it in the first place).

    System details:
    Win2k SP3
    Liteon CD-R (master) and Sony DVD-Rom (slave) on secondary IDE channel
    Symbios 810 SCSI controller (just for a scanner)
    LSI ASPI drivers

    Windows CD Player just recommends me to check the multimedia settings, Q2 reports "MCI_OPEN failed (266)".

  2. #2
    Administrator



    Join Date
    06.11.2002
    Posts
    2,044

    Default

    This is normal behavior, because MCI may not track drives dynamically - you need to reboot your system if you depend on MCI applications.

  3. #3

    Default

    Is there any way to change the default drive for such applications in Win2k or to cause the Daemon Tools to install with a different "priority"(*)? I remember such a setting in previous windows versions, but can't find it in 2k anymore.

    (*) BTW, the virtual host adaptor also grabs host adaptor ID 0 in the ASPI interface, is this changeable?

  4. #4
    Administrator



    Join Date
    06.11.2002
    Posts
    2,044

    Default

    Virtual adapter never grabs ID 0 since 3.26. What ASPI layer you use and what Daemon version?

  5. #5

    Default

    Ok, I take that bank, 3.26 is on 3,0,0 on my machine. I accidentally tab-completed an older version in my download directory when I wanted to update. This seems to have fixed the MCI order too.

Bookmarks

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •