Operating System: WindowsXP Pro
Burning Software: Nero Ultra Edition/Alcohol 120%
Anti-virus Software: NAV
DAEMON Tools Version: 3.46

So I've been using DT for a while, it's been working fine.

I then one day find that a disc won't work without a couple emulation options on, no problem, turn-em on, nothing new.

I then go to unmount the image and throw in something new, here's the problem, the cd image mounts fine, but when I go to the mounted drive directory it shows the files of what I had previously mounted.

I then unmounted, tried a different image, same thing, still the previous image files are there, they aren't useable of course because they aren't mounted anymore, but nor can I see the new mounted image files. I tried hitting refresh, no go.

I then went to re-install DT making sure I unmounted before doing so, I still couldn't use the Drive images, I then change the virtual drive letters. It worked, I even got it to mount different images several times without problem.

Now I'm loading a new image where I had to turn on the emulation options again, the problem as returned.