Page 1 of 3 123 LastLast
Showing results 1 to 10 of 22

Thread: DT Lite, Power ISO, Alcohol120 all broke!! can't mount anything anymore!!

  1. #1

    Ausrufezeichen DT Lite, Power ISO, Alcohol120 all broke!! can't mount anything anymore!!

    I've been using DT Lite foreer as well as Power ISO.
    I was installing some games with DT Lite and then when I tried to install another one, it wouldn't mount! so I uninstalled , reinstalled and still cannot get either one to mount anything!!!!

    I have no idea what went wrong, but all I was doing was installing games.

    I'm on W7 SP1
    using: DTLite4471-0337


    PLEASE HELP!!!!!!!!!!!!

  2. #2
    Customer Terramex's Avatar
    Join Date
    06.09.2004
    Posts
    2,566

    Default

    Please first try this Microsoft FixIt solution:
    Your CD or DVD drive can't read or write media

    If that doesn't solve the problem please try to manually delete upper/lower filter as described here (Resolution):
    The CD drive or the DVD drive does not work as expected on a computer that is running Windows Vista (also works on Windows XP & 7).

    btw. is your physical optical drive working ok ?
    I'm not employed by Disc Soft and my views do not necessarily reflect the ones of the company.

  3. #3

    Default

    thanks for the reply. the MS fixit solution doesn't seem to work. I will try the other one.
    yes the drive works just fine with any type of cd, dvd, game, etc.

  4. #4
    Customer Terramex's Avatar
    Join Date
    06.09.2004
    Posts
    2,566

    Default

    As your real drive is working fine I'm afraid that the manual fix probably won't work as well.

    The games you were installing before don't mount anymore ?

    Would you please create a image of any CD/DVD with DT lite: Creating disc image | daemon-help.com

    Can this be mounted ?
    Last edited by Terramex : 30.10.2013 at 19:28 Reason: typo
    I'm not employed by Disc Soft and my views do not necessarily reflect the ones of the company.

  5. #5

    Default

    ok I'm trying the second method. I found the registry key but in the instructions it says "Right Pane" "Left Pane" to delete the filters...I'm not seeing this.
    should I just delete the key itself?

    I'm on W7 SP1

    thanks

  6. #6

    Default

    basically ALL functions for ANY mounting software just isn't working. I was just installing a game after another one and when I went to install the next one, that's when all of a sudden it just wouldn't mount. I've tried PowerISO and even Alcohol120...none of them work.
    and as I said the drive does work.

    so should I just delete that whole registry key? what will happen if I do??

    thanks

  7. #7
    Customer Terramex's Avatar
    Join Date
    06.09.2004
    Posts
    2,566

    Default

    It will be automatically recreated after reboot - with fixed load order.

    Click image for larger version

Name:	upperfilters-lowerfilters.jpg
Views:	315
Size:	198.7 KB
ID:	1576
    Last edited by Terramex : 02.11.2013 at 18:11
    I'm not employed by Disc Soft and my views do not necessarily reflect the ones of the company.

  8. #8

    Default

    well I did as mentioned and.....nothing. STILL wont mount.
    how do I fix this? I rely on DT so much I really need it to work...!!

    Should I try reinstalling? I've already tried that several times

    the only message I got when rebooting was something about teh registry being changed and to re-install iTunes...whatver that means

    what other methods are there that I can use??
    I've NEVER had this problem before...

  9. #9
    Customer Terramex's Avatar
    Join Date
    06.09.2004
    Posts
    2,566

    Default

    Still looks like a filter driver issue.
    Try to (re)install the GEAR driver - (required for e.g. iTunes):
    Driver updates - GEAR Software

    Additionally, please download this tool: http://www.bustrace.com/downloads/devfilter.exe
    Run it, highlight your optical drive on the left, then highlight upper/lower filters on the right.
    Which filters are installed on your system ?
    I'm not employed by Disc Soft and my views do not necessarily reflect the ones of the company.

  10. #10

    Default

    ok I will try your suggestion
    FYI: I just updated to the latest version of DTLite and it still is not mounting, and I'm getting that message about re-installing iTunes...

    I 'll try your method and let you know what happens...

    thanks for all the help

Page 1 of 3 123 LastLast

Bookmarks

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •