Right click the key, goto permissions, goto advanced, and untick 'inherit', then click yes. Now you shuold be able to modify permissions...