Showing results 1 to 10 of 10

Thread: Error 25001, code 25021 when installing DT 3.29 on Win98SE

  1. #1

    Default Error 25001, code 25021 when installing DT 3.29 on Win98SE

    I'm trying to install 3.29.0.0 on Win98, and I'm getting the following:

    "Error 25001. Device setup error: code 25021. Contact your support personnel."

    I've tried re-installing a couple of times - no luck. The first time it happened, I just ignored the message, but upon the next boot, Windows claimed to have found an unknown device, for which it couldn't locate/recognise any driver.

    System info: Win98SE 4.10.2222 A.
    Daemon Tools 3.29
    CloneCD 4.2.0.2 - no other burning software installed

    It runs fine under Win2k on the same box, by the way.

  2. #2
    Administrator



    Join Date
    06.11.2002
    Posts
    2,044

    Default

    Delete all unknown devices in Device Manager, go to WINDOWS\INF folder
    and delete drvidx.bin file. Then try to run setup again.

  3. #3

    Default

    Tried it, same results.....

    What does the code actually mean?

  4. #4
    Administrator



    Join Date
    06.11.2002
    Posts
    2,044

    Default

    It means Windows cannot find the driver in INF file or some other error in SETUPAPI occured. When you install Daemon - do you see the message 'Windows is rebuilding driver list' with progress bar or something of that sort?.

  5. #5

    Default

    No, I don't get that far. I get as far as the "Installing DAEMON Tools" window, with the "DAEMON Tools is being installed" line, plus a full progress bar. It then takes about 15 seconds for the error message to pop up. When clicking OK, the roll back is performed.

    Arjan H

  6. #6

    Default

    Before clicking ok (before rollback);
    can you goto device manager and see if you see ST??? under scsi or PNP Bios Extension under system.

  7. #7
    New User
    Join Date
    30.01.2003
    Posts
    1

    Default

    Hi everyboby!

    Got exactly same problem with 3.29 under win98..

  8. #8

    Default

    I've only got "Virtual CloneDrive" under SCSI controllers, and I've got "PnP BIOS" and "System board extension for PnP BIOS" under system. I Also have an "Unknown Device" there.

    Arjan H

  9. #9

    Default

    @arjanh:
    Can you try the following:

    1) Right-click this unknown device, and report error code. If it wants drivers, try reinstall/update drivers, and maybe even point to C:\windows\inf.

    2) Remove this device, reboot, and check device manager again.

    Venom might have some more ideas too...

  10. #10

    Default

    ive got the same problem but i use xp ive gone though the other sulutions and none of them match is it any different for xp

Bookmarks

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •