Showing results 1 to 3 of 3

Thread: I want to purchase if I can see this issue solved.

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Frage I want to purchase if I can see this issue solved.

    I used my retail copy of LOTR Rise of the Witchking and made an image. I read that DT can get past safedisk so that I do not have to use my DVD anymore. I have the latest SPTD driver installed with reboot. The latest DT lite version. When I go to launch the game the launch screen flaashes for a moment then goes away. In the task manager it shows the process start for a couple seconds then it is gone. I have my 2 other dvd drives disabled. All that is showing is the 1 DT drive with the image mounted. I am running windows 10 pro. Everything works great when I use the retail disk. What am I missing here? Thank you very much and I am glad to finally be a part of the community. I have been strictly using Steam for trhe past 11 years. Nice to be back using DT and i see for $30 I can get access to all types of useful programs!

  2. #2

    SUPPORT1's Avatar
    Join Date


    Please note that DAEMON Tools doesn't support RMPS in Windows 10. This includes all CD-R media emulations: RMPS, Hide-CDR, Safedisc, Securom. Laser lock.

    In Windows 10 all this stuff was dropped due to several reasons:
    a) kernel architecture of Windows 10 has changed significantly with the focus to security, and hooking physical CDROM devices has become much more difficult and less safe;
    b) almost nobody uses CD-R/RW media anymore to play or backup games, and it is much faster and easier to have 1:1 image of original on a hard disk, especially if you take in account size of today's HDDs.

    So, if you need to emulate protected disc it better use previous Windows OS, like Win 7. In this case emulation of a protected disc will be successful.
    Don't worry! Be Happy!

  3. #3


    Thank you for the time saving, great reply! So is there software capable of giving me a 1:1 copy of the retail disc? I have tried imgburn, Alcohol 120%, ANYDVD, CLONE CD, and a couple others without success. Thanks again.


Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts