Showing results 1 to 8 of 8

Thread: [BUG?]Mapping don't work setting shift modifier and rumble on same button on 4.0.

  1. #1
    New User
    Join Date
    26.12.2018
    Posts
    4

    Ausrufezeichen [BUG?]Mapping don't work setting shift modifier and rumble on same button on 4.0.

    I'm not good English speaker. So my English is maybe funny. Sorry. (I'm Japanese.)

    I used shift modifier and rumble on same button on version 3.1 - 3.2.I made and have been using this config file.
    After update to version 4.0, I found mapping on the button don't work.
    This function is correctly working on version 3.2.

    To duplicate the problem, I made new config, and check it. And it is reproduced.
    I checked these config file on text editer, but any problem didn't find.
    So I think this probrem is bug, and report here.

    reWASD config file



    This config is set shift modifier on P1, P2, X or Y, and A button is mapping "A" on shift 1-4.
    In the movie, push A holding P1, P2, X or Y.

    My environment
    Windows 10
    Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz, 16 GB RAM, GeForce GTX 1060
    Xbox Elite Controller
    reWASD 4.0

  2. #2
    Administrator

    SUPPORT1's Avatar
    Join Date
    07.02.2012
    Posts
    429

    Default

    Hello,


    Thank you for bug reporting. Indeed, The button doesn't work if it has Shift Modifier (works without). Also if you switch on a toggle modifier it doesn't work inside the toggle and fires when you press a button again to shut a toggle down.


    We will investigate the problem and try to fix it ASAP.


    Thank you for the cooperation.
    Don't worry! Be Happy!

  3. #3
    Experienced User reWASDer's Avatar
    Join Date
    26.06.2018
    Posts
    200

    Default

    Hello!

    We've fixed the issue you found. Thanks a lot for your detailed report and sorry for the inconvenience. Please download the new version from rewasd.com and install.

  4. #4
    New User
    Join Date
    26.12.2018
    Posts
    4

    Default

    What a nice job did you do!
    I'm disapointed that I don't know what to compliment in English.
    Thanks a lot (/'ω')/

  5. #5
    Experienced User reWASDer's Avatar
    Join Date
    26.06.2018
    Posts
    200

    Default

    You are welcome!

  6. #6
    New User
    Join Date
    26.12.2018
    Posts
    4

    Default

    I found new bug on version 4.00.831.
    It is happen to use 2 shift modifier consimultaneously.


    Config

    In this video, I pushed P1 and P2, and release them.
    But shift and alt don't release despite paddles released.

    I couldn't find the detail, sorry.

  7. #7
    Administrator

    SUPPORT1's Avatar
    Join Date
    07.02.2012
    Posts
    429

    Default

    Hello,

    Thank you for the report. We have reproduced the problem and will try to fix it ASAP.
    We do appreciate your assistance.
    Don't worry! Be Happy!

  8. #8
    Experienced User reWASDer's Avatar
    Join Date
    26.06.2018
    Posts
    200

    Default

    Hello! Today we have released reWASD 4.0.1 with several important fixes. The one you mentioned above is fixed too. I would be grateful if you could update and try.
    You can review all release notes here.

Tags for this Thread

Bookmarks

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •