Page 1 of 2 12 LastLast
Showing results 1 to 10 of 20

Thread: Virtual 360 controller stuck as Player 2

  1. #1

    Default Virtual 360 controller stuck as Player 2

    So I can't seem to get the virtual controller to work as anything but player 2.

    So far all I've tried to do is set x and R trigger to rapid fire, which sets up a virtual controller. If I set it to hide physical Xbox One controller (connected via wireless adapter) I get no input in whatever game I'm playing unless the game supports same screen co-op and then it only works as player 2. I've tried setting the virtual 360 controller to the default device in the "setup usb game controllers" control panel, but this doesn't seem to have any effect. I have a logitech G13 gameboard hooked up with the G13 joystick disabled(as it grabbed priority in some games) so that shouldn't be affecting things. I've tried running ReWasd in administrator and that's made no difference.

    Running on Windows 10 Pro.

    Wish I could get this to work.

  2. #2



    Could you please send me the list of games you checked, so we could try them from our side?

    In the meantime, I advise you Apply the config before entering the game. So, Apply the config - the virtual controller is created - then open the game.

  3. #3


    So far I've tried Warframe, Sundered(has on screen co-op) Shantae Half-Genie Hero. Hmm, I tried applying the config before starting warframe, but once I'm in game I get no controller input at all.

  4. #4


    Hmm, tried to apply the config before opening Warframe, still no input registered by the game.

    I get a little bit input registered in Shantae Half-Genie Hero before the main menu (can move up and down between start and exit), but once I select start I get not further inputs registered on the select game data screen.

    Sundered seems to work now as it didn't work right in 4.0. I used to either control two characters at once(physical controller not hidden) or just the second player character with the controller hidden. I'm mostly trying to get it to work in Warframe as some of the semi-auto weapons can be modded to attack stupidly fast so as to require a rapid fire function to make full use of them.

  5. #5


    Thanks for the details.

    Will get back to you a bit later after we check the game.

  6. #6


    Hello again!

    We have checked Warframe and found an interesting issue. It doesn't seem to recognize the controller until the reboot. It reproduces not only for Virtual Controller but for the physical one too. We think this issue is connected to specific in-game engine and can't do anything with it.

    So, I advise you the following:
    1. Create a new config, add turbo to RT button and do not forget to Unmap this one.
    2. Apply this config, confirm to hide your physical gamepad.
    3. Ensure that tray agent and autoremap is on (these settings are default in Preferences), also ensure that you haven't disabled reWASD tray agent on startup in Windows settings.
    4. Reboot your system

    After the reboot, the remap should be on and the game will see Virtual Controller instead of your physical one.

    By the way, while testing the game we have found that it has an extremely inconvenient "Run" activator: you need to press and hold Left Stick click. We have add Toggle to it — and it worked much better With Toggle, you need to press click once to run and then press one time more to move slower. Seems it is much more convenient. As another option, you can add Left Stick click to High zone of the Left Stick in Advanced stick settings. That will activate running when you push the stick to its edge.

    Hope it will help. I would be grateful if you let us know is the reboot helped you.

  7. #7


    Well, I tried steps 1-4 and Warframe still doesn't see the virtual controller. Not sure what's going on.

  8. #8


    Hm. You mentioned that you have wireless adapter. Could you please check the same with the controller connected via cable?

  9. #9


    I get the same results wired. I wonder if resetting my Warframe config files would help, I'll see if I can figure out how to do that.

  10. #10


    Would be grateful if you try!

Page 1 of 2 12 LastLast


Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts