Showing results 1 to 5 of 5

Thread: No CD Audio in Heroes of Might and Magic 2

  1. #1

    Default No CD Audio in Heroes of Might and Magic 2

    Operating System: Windows XP
    Burning Software: Nero 6.3
    Anti-virus Software: None at the moment
    DAEMON Tools Version: 3.47

    I was on an old game kick and decided to throw HOMM2 on an image play it off the hard drive. Unfortunately, the CD audio does not seem to play when trying to run it off Daemon Tools. I've tried checking analog audio, unchecking it, and turning on or off digital audio in the device properties for the generic drive Daemon tools created, but no combinations of these work.

    The CD contains both data and audio tracks. I burned the image to a normal CDRW and it worked fine, so the image does not seem to be the issue. Oddly enough, I can play the music in Windows Media Player, but it just does not seem to work in game.
    Any ideas?

  2. #2

    Default

    Disable analog audio, ensure digital audio is enabled.
    It's possible that it works from lowest drive letter only - seems some programmers thought "noone owns two cd-drives" in those days.
    Everybody be cool! You, be cool!
    They'll keep fighting! And they'll win!

  3. #3

    Default

    Yep, it definately looks like the audio only works on the lowest lettered drive. Gonna see what I can do to work around that. Thanks for the help!

  4. #4

    Default

    Operating System: WinXP SP2 + all pre-SP3 patches
    Burning Software: Nero + ISO Recorder v2
    Anti-virus Software: NOD32
    DAEMON Tools Version: 3.47

    That implies, then, that you can use Disk Management to move your drive letter associations around. Might work if you made like the first Daemon Tools Virtual drive B:\.s

  5. #5

    Default

    Another method:
    Quote Originally Posted by Ohio813
    You assign unique drive letters (up to 4) for each virtual CD-ROM or DVD-ROM you want mounted. To control which drive letter will be used :

    Right click the DAEMON Tools tray icon... Virtual CD/DVD-ROM ... Device 0: ... Set device parameters ... There are two drop down comboboxes Drive Letter and DVD Region. Use the drive letter drop down.

    Of course you change the 'Device 0' part if you have other virtual drives.
    the modern world:
    net helpmsg 4006

Bookmarks

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •